Reply to topic

[SOLVED] Fresh install with xterminal root problem

locuras69
Registered Member
Posts
6
Karma
0
hi all guys

i have installed a fresh install of lenny (20-02-2009) not beta lenny, kde 3.5 cd install

i have installed kde 4.2 as this guide -> http://linuxsaga.com/guide/kde-42-in-de ... ting-lenny

all ok, but i have a "small" problem, i cannot run "xterminal" as root "root terminal" ... no errors i think... the mouse icon shows the small icon jumping (as a app loads) 30 seconds but never run...

when i installed kde 4.2 in a fresh install of lenny beta 2 in the past i don't see this problem, what happens here?

sorry my bad english please

thanks to all
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Try opening Konsole, then running "kdesu xterminal" and posting the output here.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
locuras69
Registered Member
Posts
6
Karma
0
kdesu xterminal
bash: kdesu: command not found

----------------------------------------------------------
aptitude seach kdesu
i kdesu - interfaz gráfica de sudo para KDE


thanks for your help bcooksley
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
Hmmm, maybe it is "kdesudo xterminal"


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
locuras69
Registered Member
Posts
6
Karma
0
hi again

if i write "kdesudo konsole" it works, but ask me for a password, but this is other problem...

kdesu konsole don't work (kdesu: command not found)

if i write "/usr/lib/kde4/libexec/kdesu konsole" it works,

i hope this helps you to help me please :-)


thanks
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
This is because some time ago for unknown reasons, kdesu was moved there, outside $PATH. You can add that to your $PATH by editing your ~/.bashrc and adding this line at the end:
Code: Select all
PATH=/usr/lib/kde4/libexec:$PATH


Then next time you login, you will be able to run kdesu without problems.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
locuras69
Registered Member
Posts
6
Karma
0
ok, done it...

but the run root konsole problem persists :-( it must be another problem...

i select "xterminal root" in Kmenu, the icon seems loading the app for 15 secs and then cursor goes normal state...
User avatar bcooksley
Administrator
Posts
19765
Karma
87
OS
What is the command for the terminal icon? ( The menu editor will let you see this )


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
locuras69
Registered Member
Posts
6
Karma
0
solved m8 :-D

i erased all, installed KDE again as this guide -> http://www.ppcnux.com/?q=kde42-on-debian-gnu-lenny

all problems fixed :thumbs_up:

the problem seems a dependency problem, or "mixed commands" between kde / gnome

i do not recomment follow this guide "http://linuxsaga.com/guide/kde-42-in-debian-testing-lenny" to install kde 4.2 in a Lenny system, just follow this one -> http://www.ppcnux.com/?q=kde42-on-debian-gnu-lenny

Thanks bcooksley for your help anyway :-)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], beerislife, Bing [Bot], dwlamb, Google [Bot], Majestic-12 [Bot], Sardus-X, semper, Sogou [Bot], Yahoo [Bot]