Reply to topic

Dolphin opening windows in background

krsnendu
Registered Member
Posts
7
Karma
0
How can I set things up so that when I open a document in dolphin the application and document are viewable straight away (without having to click on its tab at the bottom of the screen)?

e.g. When I click on an openoffice .odt document the window does not come to the front of the other windows, but opens in the background. I have to click on the window's tab at the bottom of the screen to view it.
User avatar Camden
Registered Member
Posts
11
Karma
0
OS
What Windows Manager are you using? Not the KDE default -- Maybe try to use a config tool to change that.
krsnendu
Registered Member
Posts
7
Karma
0
I am using Kwin the default.
Couldn't find any settings in dolphin or system settings to do what I want.
krsnendu
Registered Member
Posts
7
Karma
0
Seems it is an openoffice problem. When I open pdf files and open .doc using word it opens fine.
The first time I open an openoffice document it opens fine. The second and following docs open behind the dolphin window. It is not minimized, but it is below the dolphin window.

An ideas what to do?
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
Check if you have anything in System Settings -> Window Behavior -> Window Specific. For some reason I have "(Default) Disable focus stealing prevention for" for some apps, including OO.o, which I haven't set myself. This is in KDE 3.5.x, but maybe you have something similar?

If you have a rule for OpenOffice.org, you could try to disable it (e.g. by clicking "Modify" and appending '-disabled' in "Window class").


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
krsnendu
Registered Member
Posts
7
Karma
0
Hans wrote:Check if you have anything in System Settings -> Window Behavior -> Window Specific. For some reason I have "(Default) Disable focus stealing prevention for" for some apps, including OO.o, which I haven't set myself. This is in KDE 3.5.x, but maybe you have something similar?

If you have a rule for OpenOffice.org, you could try to disable it (e.g. by clicking "Modify" and appending '-disabled' in "Window class").


I didn't notice any thing for Openoffice.
User avatar Ahmad Samir
Registered Member
Posts
127
Karma
0
OS
krsnendu wrote:How can I set things up so that when I open a document in dolphin the application and document are viewable straight away (without having to click on its tab at the bottom of the screen)?

e.g. When I click on an openoffice .odt document the window does not come to the front of the other windows, but opens in the background. I have to click on the window's tab at the bottom of the screen to view it.

Right click the title bar of openoffice window >Advanced>special application settings, go to the Workarounds tab, check Focus stealing prevention, then select Force and None, see if this works.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, funkyskywalker, Google [Bot], irvingarrietavazquez, jmacleod, koffeinfriedhof, lagunacreek, lcornell, matemat, quisimodo, sanecito, semper, Sogou [Bot], steveblezy, Yahoo [Bot]