Reply to topic

Desktop sphere and cylinder in KDE 4.2 inactive

User avatar Logos
Registered Member
Posts
10
Karma
0
OS
hello,

I'm wondering how to activate the sphere or the cylinder in desktop effects. What ever I tried, only the cube is available, any clue on that one? thanks ;-)

Last edited by Logos on Sat Mar 07, 2009 6:41 pm, edited 1 time in total.


Mandriva Cooker 2010.0
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
Sphere and cylinder require compilable shaders to work and only the 'fglrx' and 'nvidia' drivers provide them. If running 'fglrx' you might need to run `KWIN_DIRECT_GL=1 kwin --replace &` from your Konsole or Alt+F2 KRunner first.
User avatar Logos
Registered Member
Posts
10
Karma
0
OS
Zarin wrote:Sphere and cylinder require compilable shaders to work and only the 'fglrx' and 'nvidia' drivers provide them. If running 'fglrx' you might need to run `KWIN_DIRECT_GL=1 kwin --replace &` from your Konsole or Alt+F2 KRunner first.


funny sphere and cylinder work in Compiz though, with the same Intel chip and drivers:)...anyway in KDE 4.3, I don't have the sphere and cylinder options anymore in Kwin effects control panel.


Mandriva Cooker 2010.0
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
Compiz probably uses either CPU processing or vertex programs instead of shaders.

The sphere and cylinder have been merged with the cube effect in KDE 4.3. You can enable them in the cube's setting dialog.
IMak
Registered Member
Posts
5
Karma
0
OS
For clarity, it "is" impossible to enable cylinder and sphere on Intel GMA only systems? I've recall having run these effects using KDE 4.2.4 but now I seemed to have lost them with the upgrade to 4.3.1. Here I thought since I'm using Gentoo I was missing a use flag or something. Can you please confirm, that these 2 animations are only possible with compiz?
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
KWin's sphere and cylinder have always required vertex shader support and Intel hardware graphics drivers do not provide this.
User avatar Visterius
Registered Member
Posts
2
Karma
0
Hello.
I have the same problem in KDE 4.3.2, the system behaves like there is no shader support. I'm using Kubuntu 9.10 for now and have ATI proprietary drivers installed through the HW manager.
Code: Select all
glxinfo | grep -i  shader
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
    GL_ARB_geometry_shader4, GL_ARB_half_float_pixel,
    GL_ARB_shader_objects, GL_ARB_shader_texture_lod,
    GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
    GL_ATI_draw_buffers, GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader,
    GL_EXT_geometry_shader4, GL_EXT_gpu_program_parameters,
    GL_EXT_gpu_shader4, GL_EXT_multi_draw_arrays, GL_EXT_packed_depth_stencil,



I tried turning on and off OpenGL direct rendering as advised here - https://bugs.kde.org/show_bug.cgi?id=173556#c17, so now when initiating the "Sharpen" effect no error is displayed - but I still can't activate it, as well as the sphere or the cylinder. It seems there is no reason for it not to work. My graphics card model is HD2400Pro. Is there anything I could do about this?
Thanks.
User avatar Visterius
Registered Member
Posts
2
Karma
0
Solved - used Envyng instead of Hardware Drivers.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], leonpollak, mattp12, michaelsc, OmarElrefaei, Rytelier, Sogou [Bot], tosky, trimahendra, Yahoo [Bot]