Reply to topic

alt+ctrl+f1 doesn't switch to text console

User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
I can't get to a text console using Alt+Ctrl+F1-F6.

After X starts but before I log in (that is, when the login screen is
still being displayed), Alt+Ctrl+F1 switches to a text console.

After either Gnome or KDE starts, Alt+Ctrl+F1 doesn't switch to a text
console. Alt+Ctrl+F12 switches to a blank screen, after which Alt+Ctrl
+F1-F6 switch to a text console. Alt+Ctrl+F7 then switches back to X,
after which Alt+Ctrl+F1-F6 again do not switch to a text console.

This is mostly just an annoyance I'd like to correct, but one of my
computers doesn't have an F12 key. It uses an old AT 84-key keyboard.
On that computer, it's more than just an annoyance.

Why don't Alt+Ctrl+F1-F6 work any more without Alt+Ctrl+F12 first?
What can I do to repair it?

My kernel is 2.6.18-194.17.1
My distro is CentOs release 5.5 (Final)
My X server is xorg-x11-server-Xorg-1.1.1-48.76.el5_5.1
My KDE version is 3.5.4-25.el5.centos.1 Red Hat
User avatar bcooksley
Administrator
Posts
19743
Karma
84
OS
This is usually the result of X server settings, as KDE / GNOME cannot capture the Ctrl + Alt + F1, etc keyboard shortcuts as they are handled by the X server itself.


System Settings and Device Actions KCM maintainer
Image
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
Any clues how to correct it?
User avatar bcooksley
Administrator
Posts
19743
Karma
84
OS
According to the manpage of xorg.conf, the following option will enable it. Note that the default behaviour is to allow these options to be used.

Code: Select all
Option "DontVTSwitch" "false"


System Settings and Device Actions KCM maintainer
Image
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
Thanks for the quick answer. Much more precisely informative than the answer I got from the Evolution folks concerning how to specify applications to open attachments: "There's the haystack; find the needle for yourself."
User avatar Hans
Administrator
Posts
3257
Karma
20
OS
Hm, so the problem has been solved then? In that case, please mark the topic as solved.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
My SA (I am not allowed root access) put the
Option "DontVTSwitch" "false"
line in the InputDevice section instead of the ServerFlags section.

After it's moved to the ServerFlags section, if that works I'll mark the topic as closed.
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
I still have the problem that on one of my computers, the keyboard doesn't have F12, so I can't switch to a text session using Alt+Ctrl+F12 and then Alt+Ctrl+F2. I tried remapping another key to F12 using .Xmodmap, but all that did was display something like "4;7~" in an Xterm.

Using a borrowed USB keyboard, Alt+Ctrl+F12 and then Alt+Ctrl+F2 does switch to a text session, so the problem isn't DontVTSwitch.

Also, All+Ctrl+Bksp no longer restarts X.

I'm running Scientific Linux release 6.5 (Carbon).

I don't think KDE is responsible for this, but just in case it is, I'm running version 4.3.4 (the one supplied with SL 6.5).

Any idea how to get to a text session if you have no F12 key? Is there something in an X configuration somewhere?
User avatar bcooksley
Administrator
Posts
19743
Karma
84
OS
This is definitely something in the X11 configuration. In my experience though, you can usually either switch to a VT or you cannot - you don't need to go to another given VT (#12 in your case) first.

Can you check for a xorg.conf file anywhere on your system (principally /usr/share/X11/ and /etc/X11/) and post the contents of that file?
Also, please make sure to check for any xorg.conf.d files and post the contents of those as well please.


System Settings and Device Actions KCM maintainer
Image
wolfi323
Registered Member
Posts
461
Karma
1
OS
vsnyder wrote:Also, All+Ctrl+Bksp no longer restarts X.

Try pressing it _twice_.

But then there's also the ServerFlag Option "DontZap", that disables it completely.

Any idea how to get to a text session if you have no F12 key? Is there something in an X configuration somewhere?

Well, here on openSUSE there is a text session on VT1 to VT6, X/KDE runs on VT7.
And yes, pressing Ctrl+Alt+F1 to Ctrl+Alt+F6 does immediately switch to the corresponding VT.
Unfortunately I have no idea why you would have to press Ctrl+Alt+F12 first.
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
bcooksley asked me to post xorg.conf, so here it is. xorg.conf.d is empty. xorg.conf refers to two module directories, but all that's in them is shared libraries -- no default configuration files. Keep in mind that I CAN switch to a text console, but only using a keyboard that has an F12 key. Maybe the problem is 'Option "XkbModel" "pc105"' -- Is there an option for pc84?

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 331.38 (buildmeister@swio-display-x64-rhel04-15) Wed Jan 8 19:53:14 PST 2014

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib64/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection
Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
luebking
Registered Member
Posts
1714
Karma
12
since it occurs with the login, it will be some runtime adjustment of the keytable

Code: Select all
setxkbmap -print
xmodmap -p


to lower your pain: check for availability of "chvt" ;-)
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
Doesn't seem to be helpful:

183: setxkbmap -print
xkb_keymap {
xkb_keycodes { include "evdev+aliases(qwerty)" };
xkb_types { include "complete" };
xkb_compat { include "complete" };
xkb_symbols { include "pc+us+ru:2+inet(evdev)+terminate(ctrl_alt_bksp)" };
xkb_geometry { include "pc(pc104)" };
};
184: xmodmap -p
xmodmap: up to 4 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x69)
mod1 Alt_L (0x40), Alt_R (0x6c), Alt_L (0xcc)
mod2 Num_Lock (0x4d)
mod3
mod4 Super_L (0x85), Super_R (0x86), Super_L (0xce), Hyper_L (0xcf)
mod5 ISO_Level3_Shift (0x5c), Mode_switch (0xcb)

185: chvt 2
Couldn't get a file descriptor referring to the console
luebking
Registered Member
Posts
1714
Karma
12
ask you SA for

Code: Select all
Section "ServerFlags"
Option "HandleSpecialKeys" "always"
EndSection


the output i asked for was not meant as fix but for inspection.
Alt_L (0xcc) & pc+us+ru:2 look fishy. do you use an alternative layout (russian)? what combo is the switch and does it work?
User avatar vsnyder
Registered Member
Posts
23
Karma
0
OS
I have no idea how the Russian keyboard got turned on, or how to turn it off. I don't use it. How do I turn it off?

I'll ask my SA to implement the server keys change. If that repairs the problem, we're done here.

There doesn't appear to be a layout for the old IBM Type M PC/AT 84-key keyboard in /usr/share/X11/xkb/rules/base.lst or .../xorg.lst. Using pc105 wasn't a problem until about a year ago. Maybe it's still not the problem.

By the way, from the login screen, I CAN switch to a text console using Alt+Ctrl+F1. As soon as KDE starts, I can no longer do it. I don't know whether KDE sabotages it, or there's something in one of my startup files that does it. I haven't tried gnome.

 
Reply to topic

Bookmarks



Who is online

Registered users: americogobbo, Baidu [Spider], Bing [Bot], davidemme, Exabot [Bot], Google [Bot], jgreenbaum, koriun, La Ninje, Majestic-12 [Bot], michelmassoud, MSNbot Media, rv8ter, Uri_Herrera, YaCy [Bot], Yahoo [Bot], zakibob