Reply to topic

KDE 5.4.2 - where can I change my keyboard layout?

richlion
Registered Member
Posts
68
Karma
0
OS
Hello,

I use two language keyboard layouts, English and Polish. I just reinstalled my Sabayon KDE and I managed to add another language. I cannot however find where I can add/change my keyboard. The language applet in the system tray used to allow me to add a language and easily change it. Now it doesn't.
Where is it now?

On another computer KDE 4.4.5 I can right-click on the applet and I can open "Keyboard layout - KDE Control Module". Not on KDE 4.5.2 - nothing, no options, applet settings.

Thanks,
Richard.

Last edited by richlion on Wed Oct 13, 2010 11:47 pm, edited 1 time in total.
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
It's in System Settings, Regional & Language -> Keyboard Layout. In 4.5 it's in the more logical place System Settings -> (Hardware ->) Input Devices -> Keyboard -> Layout.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
richlion
Registered Member
Posts
68
Karma
0
OS
I am sorry, but there is no such option like "System Settings, Regional & Language".

I have "Locale" where I can change the languages. It has "Country/Region & Language" and "Spell Checker", but there is nothing that would allow me to add a keyboard layout.
The previous KDE version had "Keyboard Layout", here it doesn't.

Last edited by richlion on Sun Oct 17, 2010 7:45 pm, edited 1 time in total.
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
Ah sorry, I mistook 4.5.2 for 4.4.2 (the title could have contributed to that. ;)). In that case, see my second sentence.

Hans wrote:In 4.5 it's in the more logical place System Settings -> (Hardware ->) Input Devices -> Keyboard -> Layout.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
richlion
Registered Member
Posts
68
Karma
0
OS
Thank you very much, worked.
I would have never guessed 8)
However, it would be nice, if I right-clicked on the Systray icon, it would open that Keyboard -> Layout applet, just like it used to.
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
No idea why they changed that, maybe it's a bug? You might want to search in https://bugs.kde.org/ and/or file a wishlist to see that the developers say.

By the way, I marked the topic as solved the official way (as explained here). :)


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
I believe 4.5 recieved a new keyboard layout system, which is likely why.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
kasstritito
Registered Member
Posts
1
Karma
0
Open the Control Panel, then go to Clock, Language, and Region. There, select Change keyboard or other input methods.

Click the Change keyboard button and add any languages your heart desires. You can have more than one keyboard layout for a language! To switch between languages, a keyboard shortcut is normally used (Shift+Alt by default, but you can change that). Windows 8 and higher have their own "mnemonic" layout (not without flaws, though)

Check the russian keyboard site for a more thorough guide and Change your keyboard layout.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Dibo, Google [Bot], hsnnsnc, Majestic-12 [Bot], nocruoro