Reply to topic

Gtk apps lookin real bad on 10.10 amd64

shakedkoffee
Registered Member
Posts
8
Karma
0
Hi guys,

I am an old gnome user, but the new KDE 4.6 blew my mind so I'm seriously thinking about making the switch. The ONLY problem I have is with gtk applications, such as nautilus or similar, which when opened look so 90', really bad, so I think there's something wrong. My suspicion goes to the fact that I'm running Ubuntu 10.10 amd64. Could I be right?

Made some searches on Google but couldn't find nothing. Any suggestions? Thanks..
User avatar google01103
Manager
Posts
6668
Karma
25
in systemsettings -> common appearance and behavior -> application appearance -> gtk styles and fonts try qtcurve

you'll probably need to add the following packages
gtk_kcm
qtcurve-gtk2
qtcurve-kde4


OpenSuse Leap 42.1 x64, Plasma 5.x

User avatar Hans
Administrator
Posts
3304
Karma
23
OS
Actually with 4.6, try oxygen-gtk - it's a GTK style that resembles the default KDE applications style (Oxygen). You might need to install the package for it as well.

Welcome to KDE by the way! It's nice to hear that you like the new release, don't hesitate to ask if there's anything else you wonder.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
shakedkoffee
Registered Member
Posts
8
Karma
0
Thanks for the reply!

I've tried both of your suggestions, installed both qt-curve and oxygen-molecule packages, unfortunately none of them worked, I still have an ugly gtk style, I wonder what the problem could be..
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
Not oxygen-molecule, oxygen-gtk :) (although I don't what's it called in Ubuntu). You also need to change the GTK style in System Settings, search for "GTK". If nothing is found you need to install gtk_kcm (or whatever it's called in Ubuntu).


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
shakedkoffee
Registered Member
Posts
8
Karma
0
I've tried to changed the gtk+ font too, but there doesn't seem to be any change in the synaptics nor evince. That's strange.
shakedkoffee
Registered Member
Posts
8
Karma
0
Ok, I've installed kcm-gtk, having already kdm-config-gtk, there doesn't seem to be any change in the looks of gtk applications.

P.S. From Synaptic: oxygen-molecule: GTK+ theme to match the oxygen widget style
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS
shakedkoffee wrote:I've tried to changed the gtk+ font too, but there doesn't seem to be any change in the synaptics nor evince. That's strange.


As far as synaptics go, have you made sure that the oxygen-gtk style and the fonts are set for the root user since that's the user the package-manager frontend is most likely running as? That is, hit alt-f2, kdesudo systemsettings, and then applying the settings?


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
Sir_Brizz
Registered Member
Posts
28
Karma
0
OS
Do you have a ~/.kde/env folder?
shakedkoffee
Registered Member
Posts
8
Karma
0
Kryten2X4B wrote:
shakedkoffee wrote:I've tried to changed the gtk+ font too, but there doesn't seem to be any change in the synaptics nor evince. That's strange.


As far as synaptics go, have you made sure that the oxygen-gtk style and the fonts are set for the root user since that's the user the package-manager frontend is most likely running as? That is, hit alt-f2, kdesudo systemsettings, and then applying the settings?


Tried that, nothing changes, neither the fonts that remain Sans (I think).

Sir_Brizz wrote:Do you have a ~/.kde/env folder?


Yes, the folder is there, but it's empty.

P.S. thanks for your help guys.
shakedkoffee
Registered Member
Posts
8
Karma
0
I'm starting to think I have a bigger problem: I cannot change ANY Gtk+ theme settings. I've tried to change the folder path since it didn't include the /usr/share/themes folder but nothing changed. Even with root priviledges nothing changes. I cannot even change the fonts. There must be something terribly wrong (ok, now I'm overreacting) with my installation.

Oh I want KDE soooo baaaaadly
User avatar Hans
Administrator
Posts
3304
Karma
23
OS
You can try the following (I'm not sure if it'll work):

1. Create a file called .gtkrc-2.0-kde4 in your home folder (it'll be invisible by default).
2. Add the following text to it:
Code: Select all
include "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc"
include "/etc/gtk-2.0/gtkrc"

gtk-theme-name="oxygen-gtk"

3. Make sure the two paths are valid on your system, otherwise you might need to change them.
4. Save the file.
5. Try to open a GTK application, for example GIMP.

If it doesn't work, can you please post a screenshot of your GTK module in System Settings (where you change the GTK theme)?


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
Sir_Brizz
Registered Member
Posts
28
Karma
0
OS
Do you already have this file .gtkrc-2.0-kde4 in your home folder? In your kde/env folder create a file called gtk2-engines-qtcurve.rc.sh and put the following in it:
Code: Select all
#!/bin/bash

# Make sure our customised gtkrc file is loaded.
export GTK2_RC_FILES=$HOME/.gtkrc-2.0-kde4

I had t have this file or GTK apps would be unstyled.
shakedkoffee
Registered Member
Posts
8
Karma
0
Sir_Brizz wrote:Do you already have this file .gtkrc-2.0-kde4 in your home folder? In your kde/env folder create a file called gtk2-engines-qtcurve.rc.sh and put the following in it:
Code: Select all
#!/bin/bash

# Make sure our customised gtkrc file is loaded.
export GTK2_RC_FILES=$HOME/.gtkrc-2.0-kde4

I had t have this file or GTK apps would be unstyled.


It worked!!! Great!! Thank you so much Sir_Brizz and Hans!
SorryGoFish
Registered Member
Posts
1
Karma
1
Thanks for the help. I had a similar situation. For me, the above fixes were being automatically undone (gtk2-engines-qtcurve.rc.sh was being deleted at login). To fix this I had to install "kubuntu-default-settings." I initially installed "kde-standard" from Ubuntu 10.10 minimal.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], mossbliss, Sogou [Bot], Stephen Leibowitz, Yahoo [Bot]