Reply to topic

Windows auto-resize width

alvin
Registered Member
Posts
12
Karma
0
OS

Windows auto-resize width

Thu Nov 17, 2011 8:35 am
I experience something irritating every time I
- launch a program (e.g. Konsole)
- launch a program that was minimized to tray
- move a window from one (Twinview) screen to another

In all those cases, the window will maximize the width and stick to the left and right of the monitor. Resize manually and move the window to another monitor, and it'll maximize again.

I can't find the setting that configures this weirdness.
User avatar Hans
Administrator
Posts
3304
Karma
23
OS

Re: Windows auto-resize width

Thu Nov 17, 2011 9:16 am
Is it because you drag it to the top of the screen? In that case: System Settings -> Workspace Behavior -> Screen Edges -> uncheck "Maximize windows by dragging them to the top of the screen".

This doesn't fix the first two issues, however. Which applications does it happen to?


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
alvin
Registered Member
Posts
12
Karma
0
OS

Re: Windows auto-resize width

Thu Nov 17, 2011 9:51 am
No, I'm not dragging the window to the top. If I do that, it (correctly) maximizes completely.

I thought every application does it, but it looks like I'm mistaken here. It happens with my most-used applications. Konsole and Opera.
User avatar einar
Administrator
Posts
3402
Karma
7
OS

Re: Windows auto-resize width

Fri Nov 18, 2011 6:43 am
Middle clicking on the minimize/maximize buttons should toggle that behavior off and on (yes, I've been bitten by this myself).


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
alvin
Registered Member
Posts
12
Karma
0
OS

Re: Windows auto-resize width

Tue Nov 22, 2011 8:58 am
einar wrote:Middle clicking on the minimize/maximize buttons should toggle that behavior off and on (yes, I've been bitten by this myself).


When should I do that? Middle clicking the minimize button of Konsole does nothing. Middle clicking the maximize button maximizes konsole. If I (middle of left) click that button again, Konsole reverts to its default height, but the width stretches again.
User avatar einar
Administrator
Posts
3402
Karma
7
OS

Re: Windows auto-resize width  Topic is solved

Thu Nov 24, 2011 6:47 am
Sorry, it was right click on the maximize button (I just tested this).


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
alvin
Registered Member
Posts
12
Karma
0
OS

Re: Windows auto-resize width

Thu Nov 24, 2011 8:37 am
einar wrote:Sorry, it was right click on the maximize button (I just tested this).


Whoa! You're absolutely right! That fixes it. So, it wasn't a bug but a feature after all.

Thanks a lot!
veger
Registered Member
Posts
1
Karma
0
OS

Re: Windows auto-resize width

Mon Dec 05, 2011 7:04 pm
Is there an option to permanently turn off this 'feature'?
It does work for me, but I have to right-click every time I open konsole again...
ak2766
Registered Member
Posts
1
Karma
0
OS

Re: Windows auto-resize width

Wed Feb 01, 2012 2:12 pm
I have noticed that if I use left|right split view, this "feature" is turned on. It was driving me crazy until I saw this fix. I believe it is more a bug than a feature being that it is inadvertently turned on as a side effect to another feature and it is not turned off when leaving split view mode!

Cheers,
ak.
User avatar SecretCode
Registered Member
Posts
33
Karma
0
OS

Re: Windows auto-resize width

Sat Feb 04, 2012 8:11 pm
I'm also affected by this - it most commonly affects LibreOffice windows but not (that I can remember) Dolphin or Konsole windows. LibreOffice windows are sometimes maximised horizontally (this seems to happen with LibreOffice Calc) or vertically (mostly with Writer) - and this happens even if they were not maximised in either dimension on the original screen.

As for the OP, when dragging a window to the other screen in a Twinview setup.


I'd rather be locked out than locked in
aram.nigiyan
Registered Member
Posts
1
Karma
0
OS

Re: Windows auto-resize width

Thu Feb 09, 2012 5:39 am
alvin wrote:I experience something irritating every time I
- launch a program (e.g. Konsole)
- launch a program that was minimized to tray
- move a window from one (Twinview) screen to another

In all those cases, the window will maximize the width and stick to the left and right of the monitor. Resize manually and move the window to another monitor, and it'll maximize again.

I can't find the setting that configures this weirdness.


Same for me. This is very irritating! Do we need to submit this report to more official place, since no concrete answer/solution so far?
sam2
Registered Member
Posts
1
Karma
0
OS

Re: Windows auto-resize width

Sat Feb 18, 2012 3:20 pm
I was able to turn off this behavior per-application from the menu obtained by right clicking in the title bar, then "Advanced->Special Window Settings->Size & Position" Select Maximized horizontally or vertically, choose appropriate setting ("Apply Initially" or "Does Not Affect" worked for me) and check No.
User avatar SecretCode
Registered Member
Posts
33
Karma
0
OS

Re: Windows auto-resize width

Sat Feb 18, 2012 8:01 pm
That sounds like a useful suggestion ... but it's not working for me. LO Writer windows still opening maximised vertically!


I'd rather be locked out than locked in
CliffordK
Registered Member
Posts
1
Karma
0
OS

Re: Windows auto-resize width

Sun Feb 26, 2012 10:31 am
Mine is only resizing height, and not width.
Using nVidia Xinerama

Seems to affect Dolphin (only?) At least Dolphin is the most used and annoying.
Oops, also affects the KDE System Settings Window.
Also Konqueror

KDE Version 4.7.4, Fedora 16


It initially opens Dolphin maximized height. Generally maximized to Screen 1 height.

When I move Dolphin to Screen 2, it maximizes it to screen 2 height. I shrink it back down and move it back to screen 1. It then maximizes it to Screen 2 height again (which extends beyond the bottom of screen 1 by quite a bit).

There were several "Snap To" settings that had to be disabled.

KDE System Settings
Window Behavior
Moving
Boarder Snap Zone - Disabled
Window Snap Zone - Disabled
Center Snap Zone - Disabled
Snap Windows only when Overlapping - Disabled

KDE System Settings
Workspace Behavior
Screen Edges
Uncheck all the boxes on the page (both on the screen and below).

Ahhh
Thanks SAM2. You got it...
Right Click on Top Bar (of Dolphin)
Advanced
Special Window Settings
Size and Position
Check "Maximized Vertically".
Click Apply Initially
Check NO!
Click on "OK"
Now, make sure the window is not maximized, and close all open Dolphin windows.
Re-open, and it doesn't maximize when dragging to the other window.


You seem to be able to get to the same settings here, but you can set it for all KDE applications, rather than individually.
KDE System Settings
Window Behavior
Window Rules
NEW
Size and Position
Check Maximized Vertically (or horizontally if a problem)
Click on Apply Initially
Check NO
Click on "OK". You will get a warning that you've set "Window Class to Unimportant", click on "Continue".
Click on "Apply"

Once you've set it, it seems to keep the value even if you delete the settings.
So, I would also consider this to be a BUG. As, when you first open the settings from an application such as Dolphin, the options are greyed out, but it is set to "YES".

Anyway, with the settings above, it is WORKING CORRECTLY, i.e. no longer maximizing my windows with odd movements.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], caz, Don B. Cilly, Google [Bot], khatami, Majestic-12 [Bot], Sogou [Bot], Yahoo [Bot]