Reply to topic

Plasma-desktop and virtuoso-t hogging my CPU on login

User avatar iskendar
Registered Member
Posts
48
Karma
0
OS
Hi all,

I'm running kde 4.7.4 on kubuntu 11.10, which in the beginning ran smoothly. But now after a few months I've been having this problem when logging in: apps and panels appear no problem, but the background and widgets remain blank for a few minutes, krunner doesn't respond, the launcher doesn't respond and when I drag windows, they leave a trace behind. Sounds like problems with kwin and plasma-desktop. So when I look at system activity (which launches no prob on ctrl-esc), I see that virtuoso-t takes up 50% of my CPU usage, and somewhat later plasma-desktop appears and they both take up about 25% CPU each. Later their CPU use drops to 3% or so and the desktop works normally again. Any ideas on what may cause this, and how to remedy it?


iskendar, proud to be a member of KDE forums since 2008-Dec.
User avatar bcooksley
Administrator
Posts
19756
Karma
86
OS
This sounds like Nepomuk is being very slow at responding to queries causing Plasma Desktop and KWin to block up heavily. This is in line with Virtuoso using a large quantity of CPU power.

How many Activities does your system have? Activities uses Nepomuk to power some of it's work.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar iskendar
Registered Member
Posts
48
Karma
0
OS
bcooksley wrote:This sounds like Nepomuk is being very slow at responding to queries causing Plasma Desktop and KWin to block up heavily. This is in line with Virtuoso using a large quantity of CPU power.

How many Activities does your system have? Activities uses Nepomuk to power some of it's work.


I made about 8 activities with 4 of those typically being suspended/switched off/whatever it's called and the rest on. None of them are widget-heavy, couple of folder views, a couple of desktop icons, a launcher and on my "Web" activity a lancelot contacts widget. I use the activities mostly as context for my...well...activities I guess :) than as widget bling panels.
My machine is an 2.4GHz i5 on a H67 board with 8Gb ram and the OS on an SSD and /home on a 7200rpm disk, so while it's not a total beast, it's no slouch either. I was thinking of putting the non-data part of my home directory on the SSD as well for a speedup, but actually the pc should perform ok as is.


iskendar, proud to be a member of KDE forums since 2008-Dec.
User avatar einar
Administrator
Posts
3347
Karma
7
OS
I know that recently on IRC some people have been trying to figure out why virtuoso-t sometimes goes haywire. For some scenarios, it looks like a bug in virtuoso-t itself: the developers at OpenLink have been notified of the problem.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar atrox
Registered Member
Posts
209
Karma
0
OS
In my case virtuoso-t started taking 100% of CPU whenever it can after starting using KMail (again), for which I also re-enabled Nepomuk. So I guess it's somehow related to e-mails, because I don't use activities at all.

Today virtuoso-t process has been running on 100% CPU for 6 hours, most of the time while KMail is closed and Akonadi processes are idle.

Now I disabled Nepomuk and virtuoso-t is gone, woohoo!
User avatar iskendar
Registered Member
Posts
48
Karma
0
OS
atrox wrote:In my case virtuoso-t started taking 100% of CPU whenever it can after starting using KMail (again), for which I also re-enabled Nepomuk. So I guess it's somehow related to e-mails, because I don't use activities at all.

Today virtuoso-t process has been running on 100% CPU for 6 hours, most of the time while KMail is closed and Akonadi processes are idle.

Now I disabled Nepomuk and virtuoso-t is gone, woohoo!


Aha. Yes, I'm also running KMail. 100% I haven't got yet, 50% I did yesterday. Today everything started instantly without trouble. I still would like to find a solution without disabling nepomuk, things seem to be stabilizing compared to the older kde versions.


iskendar, proud to be a member of KDE forums since 2008-Dec.
User avatar einar
Administrator
Posts
3347
Karma
7
OS
The 100% CPU issue is due to indexing of mails. See the this topic for further information.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar atrox
Registered Member
Posts
209
Karma
0
OS
einar wrote:The 100% CPU issue is due to indexing of mails. See the this topic for further information.


I'd expect indexing to stop when neither KMail nor Akonadi IMAP process etc. are not running. But well.. I guess it's not meant that way then.
User avatar einar
Administrator
Posts
3347
Karma
7
OS
If CPU keeps on being 100% after this is off, it's a virtuoso-t bug currently being investigated by the people at OpenLink.


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar iskendar
Registered Member
Posts
48
Karma
0
OS
Well, here it's 50%, but it's still pretty annoying.
Been switching off mail indexing in a ton of mail folders, no change.
Started up without kmail running, still no change.
Any workarounds until said bug is fixed? Disabling nepomuk?


iskendar, proud to be a member of KDE forums since 2008-Dec.
User avatar atrox
Registered Member
Posts
209
Karma
0
OS
I think virtuoso-t will take as much CPU as it can, while not disturbing other processes, so when your machine is idle, it'll take near 100%, if you do smth with it, it takes what's left over of your other tasks. So yes, actually I don't see 100% either.

And yes, workaround seems to be to disable Nepomuk. And I guess it is not a bug, but rather the process is very lengthy as in my case I have around 100k e-mails to index.
User avatar einar
Administrator
Posts
3347
Karma
7
OS
Apparently there will be some work in this area soon, according to this message: http://lists.kde.org/?l=kde-pim&m=132846290628021&w=2


"Violence is the last refuge of the incompetent."
Image
Plasma FAQ maintainer - Plasma programming with Python
User avatar toad
Global Moderator
Posts
1122
Karma
6
OS
virtuoso-t eating 154% CPU but no kmail and indexing suspended. Very strange...

Image


User avatar toad
Global Moderator
Posts
1122
Karma
6
OS
"Solved" it by stopping nepomuk in systemsettings, getting rid of ~/.kde4/share/apps/nepomuk and restarting nepomuk.

virtuoso now hovers around 40% or 50% and doesn't bother me any further although it has to index 2TBs worth of data.


User avatar bcooksley
Administrator
Posts
19756
Karma
86
OS
Next time you manage to get Virtuoso to spin at 100%, you might want to look at http://vhanda.in/blog/2012/02/virtuoso-going-crazy- to see if you can help provide information to get this issue squashed once and for all.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: aguinaldoalves, Baidu [Spider], Bing [Bot], dstrong, Exabot [Bot], Google [Bot], Hans, rumangerst, Sogou [Bot], tpayne, wendym, Yahoo [Bot]