Reply to topic

GTK apps look terrible under KDE

User avatar impetiredome
Registered Member
Posts
6
Karma
0
OS

GTK apps look terrible under KDE

Sun Oct 28, 2012 7:20 pm
As the title of the topic says, GTK+ apps look terrible under KDE and the System Preferences panel GTK appearance doesn't work.

A screenshot of Postler running under KDE


With a bit of googling, I found this: https://wiki.archlinux.org/index.php/Un ... _procedure

When I do that, GTK apps look native. Until I log out.
So, I discover that the 'Apply colors to non-KDE4 applications' checkbox should be unchecked. Did it, and the same thing happens again.

What happens is that KDE replaces the gtkrc file with this bit of code every time I log in:

Code: Select all
# created by KDE, pet lis 26 11:49:20 2012
#
# If you do not want KDE to override your GTK settings, select
# Appearance -> Colors in the System Settings and disable the checkbox
# "Apply colors to non-KDE4 applications"
#
#

gtk-alternative-button-order = 1



I don't care about button order, I just want the apps to look native.

I have oxygen-gtk install and I'm using KDE 4.8.4 on LMDE update pack 5 [Debian Wheezy + a bit of Mint stuff]
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
To the best of my knowledge, KDE should not be altering the gtkrc file.
Does this occur under a new user?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar impetiredome
Registered Member
Posts
6
Karma
0
OS

Re: GTK apps look terrible under KDE

Mon Oct 29, 2012 11:57 am
I logged in to my (other) account and apps look native without any tweaks. I'm really confused. ???
User avatar starbuck
Registered Member
Posts
57
Karma
0
OS

Re: GTK apps look terrible under KDE

Mon Oct 29, 2012 12:07 pm
Have you tried this KCM module to set style (or simply control what is set):
http://packages.debian.org/sid/kde-config-gtk-style


Blue Systems: http://www.blue-systems.com
Netrunner GNU/Linux: http://www.netrunner.com
User avatar impetiredome
Registered Member
Posts
6
Karma
0
OS
I did try it, and it doesn't work.
impetiredome wrote:...and the System Preferences panel GTK appearance doesn't work...
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
Please check for scripts in the following locations:
Code: Select all
~/.kde4/env/
~/.kde4/Autostart/
~/.config/autostart


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar impetiredome
Registered Member
Posts
6
Karma
0
OS

Re: GTK apps look terrible under KDE

Wed Oct 31, 2012 10:20 am
Nothing in the first two, but in ~/.config/autostart:
Code: Select all
027BF8713FF1D969AF9CAC6308A84BD85CC270F0.google-chrome-service.desktop
cairo-dock.desktop
Compiz.desktop
docky.desktop
dropbox.desktop
gnome-do.desktop
gnome-keyring-gpg.desktop
gnome-keyring-secrets.desktop
gnome-keyring-ssh.desktop
mintupload.desktop
mintwelcome.desktop
nautilus-autostart.desktop
postler.desktop
Screenlets Daemon.desktop
xfce4-clipman-plugin-autostart.desktop
xfce4-settings-helper-autostart.desktop

Also, I don't have ~/.kde4. Instead, there's ~/.kde
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
I see a "xfce4-settings-helper-autostart" in there - which means XFCE could be applying it's Gtk theme preferences...
Try eliminating those if possible and see if the issue with regards to overwriting of your Gtk settings persists.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar impetiredome
Registered Member
Posts
6
Karma
0
OS
Deleted it and the issue persists.
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS

Re: GTK apps look terrible under KDE

Fri Nov 09, 2012 11:12 pm
After login, can you have a look to see if any GNOME / Gtk / etc settings daemons appear to be running?
(For both users).


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar impetiredome
Registered Member
Posts
6
Karma
0
OS
In my account, gconfd-2 and gnome-keyring-daemon.
Will check for the other user account later.
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
gconfd-2 could possibly be overriding the KDE settings... try looking for the gconfd storage (~/.gconf or similar) and moving it elsewhere with gconfd-2 not running.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Algar, arucard, Baidu [Spider], Bing [Bot], capslock, Exabot [Bot], gdquest, Google [Bot], lueck, neverendingo, rapiteanu, smankowski, SPRog, wolfi323, Yahoo [Bot]