Reply to topic

dictionary widget not working -- kde 4.9.5

mwcEDK
Registered Member
Posts
2
Karma
0
OS
Hi,

I'm using kde 4.9.5 under fedora 17, and the dictionary widget doesn't respond with a definition after a word is entered. Nothing appears to happen -- I verified that no internet traffic is generated (using tcpdump) when a word is entered. If I select "dictionary settings" by clicking on the "ABC" icon, a blank dialog box is displayed. A quick grep of .kde turns up two files:

./share/config/plasma-desktop-appletsrc:dictionary=en_US
./share/config/plasma-desktop-appletsrc:plugin=dict

[Containments][3][Applets][44][Configuration]
dictionary=en_US

I suspect the issue I'm experiencing may be due to some missing configuration info.

Any hints would be appreciated.

Thanks for your time,
Mike
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
Does the Dictionary runner in KRunner work?


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
mwcEDK
Registered Member
Posts
2
Karma
0
OS
bcooksley wrote:Does the Dictionary runner in KRunner work?


I don't see any dictionary runner listed when I call up krunner. Am I missing a necessary KDE package?

Thanks.
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
The dictionary runner should be part of kdeplasma-addons. Confusingly however, the dictionary applet is also in kdeplasma-addons.
It may also be worth checking to see if the 'dict' data engine is installed on your system. The easiest way to do this is probably with "plasmaengineexplorer" and seeing if "dict" is selectable from the drop down menu.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], davidemme, Exabot [Bot], Google [Bot], hein, Kver, lilliecraig, Majestic-12 [Bot], nezumi, rbysh, Sogou [Bot], supaiku, Yahoo [Bot]