Reply to topic

Restore default KDE4 taskbar settings

zerogeer6
Registered Member
Posts
2
Karma
0
I somehow managed to delete the taskbar from my new install of KDE 4. I was trying to remove one of the extra clocks and such it had two of on the tray and everything went downhill from there. Can someone please help me and let me know how to restore this back to its original form? I am rather new to Linux, treat me like a new Windows convert and walk me through. I would really appreciate the help.

Thanks in advance!
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
Do the following in a terminal:
Code: Select all
kquitapp plasma
rm ~/.kde4/share/config/plasma-appletsrc
plasma &
zerogeer6
Registered Member
Posts
2
Karma
0
Zarin wrote:Do the following in a terminal:
Code: Select all
kquitapp plasma
rm ~/.kde4/share/config/plasma-appletsrc
plasma &



On the money, thank you kindly for your help. I wish there would have been something in the FAQ about these 'oh ****' situations. I am sure I am not the only one who has done this before. :)
User avatar Cypher
Registered Member
Posts
28
Karma
0
OS
Alternatively, you can re-add the widget to the panel by using the Add Widget menu. Unlock the widgets to do so, and click the Add Widget, all using the Cashew or by right-clicking on the desktop.


Cypher, proud to be a member of KDE forums since 2008-Oct.
broncotrolley
Registered Member
Posts
2
Karma
0
So....I seem to have messed up my panel quite a bit. When I try to add widgets to the bottom panel they dont work in some way...the app launcher is shows up in the middle, the taskbar creates weird lines everywhere...basically that option won't work. So then I tried following the instructions here, only to find that ~/.kde4/share/config/plasma-appletsrc does not exists. In fact, I don't even have a .kde4 FOLDER.

I installed kde 4 from an ubuntu installation using aptitude install kubuntu-kde4-desktop. What is going on.
User avatar neverendingo
Administrator
Posts
2136
Karma
17
OS
Then you are for sure running ubuntu intrepid. That means they now run the home dir of KDE4 in .kde/, so the full path has to be ~/.kde/share/config/plasma-appletsrc

Last edited by neverendingo on Wed Nov 19, 2008 11:13 pm, edited 1 time in total.


New to KDE Software? - get help from Userbase or ask questions on the Forums
Communicate.
Image
broncotrolley
Registered Member
Posts
2
Karma
0
Ah thanks so much.
jayo777
Registered Member
Posts
1
Karma
0
Whew! I am glad to see that I am not the only one that had this problem or found this fix to be, "just what the Dr. ordered!" Although, I have to admit another "noob" move.

Since I had nothing on my screen and was only able to right mouse click to be able to initiate the Run command; I issued the first on the list of suggested commands, being the "kquitapp plasma" command and found myself with a black screen, with only my mouse pointer to keep me company!

Of course the fear factor was low since I knew that I could give it the 3 finger solute and at least logout and back in. After doing this, I then opened a konsole terminal window and after typing in the command, it came back stating that the file did not exist. I then thought, about using "sudo", but even that did not work. I opted to follow the path myself and discovered that in fact the file was there.

I gave the "sudo rm plasma-appletsrc" command and that removed it. I then gave the next command of "plasma &" and everything went smoothly from there. After logging out and back in, everything is back where it was originally.

Thanks for all of the help! I was forced to use Gnome, since I had so thoroughly hosed up KDE, but now I am home once again! Aaaagh! :o)

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], lueck, Majestic-12 [Bot], uyenb, Yahoo [Bot]