Reply to topic

My Laptop cannot shutdown/logout properly

mrousavy
Registered Member
Posts
6
Karma
0
OS
So I've finaly completed my KDE Installation and set everything up - only to notice that everytime I try to shutdown/reboot/logout, my KDE just freezes at the desktop screen shortly before the screen would go black.

I've just now fully reinstalled KDE Neon on the laptop without the third party drivers this time, and I did not change anything. I just let it at the default settings, and tried to shutdown. Same thing. Just freezing. Same with the Installer USB Drive, I can't shutdown that either.

Can anyone help me resolve this issue?

Additional Info:
* Laptop: XPS 15 (9560)
* OS: KDE Neon User Edition
* Graphics: 4k, NVIDIA GTX 1050
* RAM: 32GB, Swap: 32GB
* CPU: Intel i7 7700k
* Drive: 1TB M.2
* Other: I've got windows on there aswell, 500GB Windows, 500GB KDE Neon


It's a completely fresh install, I have really no idea what to do - and killing it everytime doesn't sound good especially because I just got the laptop yesterday...
Thanks!
mrousavy
Registered Member
Posts
6
Karma
0
OS
Switched to windows for now. Hopefully someone can help me out here, I'd love to use KDE but not shutting down is a serious issue.
User avatar subdiff
Registered Member
Posts
49
Karma
0
OS
You're using Nvidia's proprietary driver?

You can also try the hwe stack:
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

Btw: Your swap is very big. With 32gb you practically don't need any swap at all (but suspend to disk won't work).
mrousavy
Registered Member
Posts
6
Karma
0
OS
subdiff wrote:You're using Nvidia's proprietary driver?

Yeah well I installed it once with third party drivers, and once without (if that's the proprietary drivers)

subdiff wrote:You can also try the hwe stack:
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

Both are already installed with the newest version... (I've just tried it on the installer USB stick instead of a real KDE Neon installation, does that make a difference?)

EDIT: Well I can't shutdown the USB either.. :/

subdiff wrote:Btw: Your swap is very big. With 32gb you practically don't need any swap at all (but suspend to disk won't work).

Good to know - thanks!
mrousavy
Registered Member
Posts
6
Karma
0
OS
Can this be a problem with xorg? Can I try with wayland somehow?
johnpaulding
Registered Member
Posts
25
Karma
0
OS
Yes, you only need 2-4gb swap and only for suspend/hibernate.

I've got 4 older thinkpads and could only get neon to work on two of them and with the other two, it was display issues as well. I was able to install alternative versions of plasma, namely kubuntu and kstudio. Another option that worked was installing lubuntu and then installing plasma-desktop. iirc, I could only go as high as plasma 4.4 on one machine.

I would try kubuntu. You'd still get plasma5 and the kde apps. In fact, more kde apps are pre-installed with kubuntu I think.

Kstudio isn't as customizable and it comes with a ton of audio apps that you probably wouldn't need but it's not difficult to uninstall. Come to think of it, kstudio is plasma 4.x (4.4 I think)
mrousavy
Registered Member
Posts
6
Karma
0
OS
Update: When hitting Ctrl + Alt + F2 or any other F key to switch tty session, my system fully freezes aswell.

How can I start KDE Neon using Wayland instead of xorg on my Installer USB? I don't wannt to actually install it until I can logout/shutdown...
mrousavy
Registered Member
Posts
6
Karma
0
OS
Update2: Running `qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 0 0 0` does not work either, desktop elements (Windows, Taskbar and Mouse) slightly dim but it freezes there aswell.

This is really frustrating, can someone please help me out here?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], crispiatico, Exabot [Bot], Google [Bot], louis94, Nyugame, Sogou [Bot], sudo0272, Yahoo [Bot]