Reply to topic

Making Plasma The Default Desktop

User avatar mrgrimm
Registered Member
Posts
64
Karma
0
OS

Making Plasma The Default Desktop

Tue Apr 09, 2019 7:48 pm
i have linux mint cinnamon installed and a few months back i installed the dke plasma desktop to have the kde apps in cinnamon. at that time though plasma was a bit unstable so i only logged into it like 3 times cause it would have problems. today because of a couple of issues with dolphin in cinnamon i decided to log into plasma and it's nice and stable now. i want to run it for a while but do not know how to make it the default desktop. help with this would be greatly appreciated. thanks


KDE Neon 64 Bit On Kernel 5.1, 430 nVidia Driver
Asus 970 Gaming/Aura, AMD FX 6300, 16Gig DDR3,
Samsung 120Gig 850 EVO, AOC 29" Ultra Wide 2560x1080, nVidia 750Ti,
USB 3 Card, Drives 2TB, 1.5TB, 1TB / 750Gig, 500Gig
timfox
Registered Member
Posts
3
Karma
0
You should be able to set this up by editing your $HOME/.dmrc file. The sessions available to your display manager (whichever one you use) are .desktop files normally located in /usr/share/xsessions. In my case, this directory contains:

$ ls /usr/share/xsessions
cinnamon2d.desktop gnome-fallback.desktop openbox-gnome.desktop xfce.desktop
cinnamon.desktop mate.desktop openbox-kde.desktop
gnome.desktop openbox.desktop ssh.desktop
Any of those files is a possible session that my display manager can choose. Which one is controlled by the $HOME/.dmrc file. So, to make KDE the default, you would have to edit that file and make it look like this:

[Desktop]
Session=kde-plasma
That assumes that you have a kde.desktop file in the xsessions directory, I don't use KDE so I can't check but it works for me using cinnamon or xfce. Once you have made that change, you should be logged in to KDE by default every time.
User avatar mrgrimm
Registered Member
Posts
64
Karma
0
OS

Re: Making Plasma The Default Desktop

Wed Apr 10, 2019 11:46 am
timfox thanks for the info, very much appreciate. will def save it for future use. i lucked out, cause it looks like simple updating my vid drivers from the 390 nvidia to the 418 nvidia did the trick. had to restart to fix a issue and expected to land on the cinnamon desktop was taken to plasma's instead. dumb luck, but works for me. thanks again.


KDE Neon 64 Bit On Kernel 5.1, 430 nVidia Driver
Asus 970 Gaming/Aura, AMD FX 6300, 16Gig DDR3,
Samsung 120Gig 850 EVO, AOC 29" Ultra Wide 2560x1080, nVidia 750Ti,
USB 3 Card, Drives 2TB, 1.5TB, 1TB / 750Gig, 500Gig
airdrik
Registered Member
Posts
1698
Karma
4
OS
Display managers will usually remember which desktop each user used last and use that the next time (until they select something different); so setting something explicitly as the default usually isn't necessary.


airdrik, proud to be a member of KDE forums since 2008-Dec.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], cya, davide445, Google [Bot], janpla, jeffgila, jmacleod, Majestic-12 [Bot], Mamarok, TechnoJunky, TheBeheader, wind_rose_2