Reply to topic

Disable desktop switch on mouse wheel / vertical scroll

McCloud
Registered Member
Posts
1
Karma
0
Hello,

I'm running KDE 4.2RC (Kubuntu) with KWin as my Window Manager. Currently the mouse wheel (or vertical scrolling on my touchpad) triggers a desktop switch. This behavior really annoys me and I would like to switch it off.

In Compiz I have been able to switch it off by editing the settings of the Viewpoint Switcher. I can't however find a way to disable this behavior in KWin. Does somebody know how to disable this?

Thanks for your help.
User avatar Zarin
KDE Developer
Posts
345
Karma
8
OS
This annoying feature is a part of Plasma and happens when you scroll when the mouse cursor is over the desktop. I am uncertain to whether or not it is configurable.
User avatar JontheEchinda
KDE Developer
Posts
309
Karma
4
OS
I hate it too.


JontheEchinda, proud to be a member of the Kubuntu team since July 2008.
Image
Image
User avatar msoeken
Mentor
Posts
300
Karma
4
OS
I took a look in the code (see Containment::wheelEvent). It seems not to be configurable.

EDIT: But it could be for KDE 4.3. There is a bug report.

Last edited by msoeken on Thu Jan 22, 2009 2:26 pm, edited 1 time in total.


Image
[size=x-small]code | [url=cia.vc/stats/author/msoeken]cia.vc[/url] | [url=kde.org/support]donating KDE[/url] | [url=tinyurl.com/cto4ns]wishlist[/url][/size]
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS
Zarin wrote:This annoying feature is a part of Plasma and happens when you scroll when the mouse cursor is over the desktop. I am uncertain to whether or not it is configurable.


For what it's worth, I noticed the other day that it's containment-specific so if you REALLY need to turn the behavior off, you can switch to a old-school style desktop (with the drawbacks that may entail...)


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
User avatar msoeken
Mentor
Posts
300
Karma
4
OS
Kryten2X4B wrote:
Zarin wrote:This annoying feature is a part of Plasma and happens when you scroll when the mouse cursor is over the desktop. I am uncertain to whether or not it is configurable.


For what it's worth, I noticed the other day that it's containment-specific so if you REALLY need to turn the behavior off, you can switch to a old-school style desktop (with the drawbacks that may entail...)


What do you mean with old-school desktop? The folder view containment?


Image
[size=x-small]code | [url=cia.vc/stats/author/msoeken]cia.vc[/url] | [url=kde.org/support]donating KDE[/url] | [url=tinyurl.com/cto4ns]wishlist[/url][/size]
Kryten2X4B
Registered Member
Posts
911
Karma
4
OS
msoeken wrote:
What do you mean with old-school desktop? The folder view containment?


Sorry. Yes, that's what I mean. Not the best solution maybe, but a workaround nonetheless.


OpenSUSE 11.4, 64-bit with KDE 4.6.4
Proud to be a member of KDE forums since 2008-Oct.
theluckyone17
Registered Member
Posts
1
Karma
0
I've ran across this, too... only, I like the desktop scrolling feature.

I hope "they" bring KDE 4 back to the configurable nature of 3. Why they'd tie desktop "scrolling" to being able to display the desktop icons, I don't know. Maybe the icons aren't the purpose of classic desktop, but...
rambotribble
Registered Member
Posts
1
Karma
0
Even though this is an old thread, since it is what came up when I searched the topic, it should be answered. The solution is to right-click on the desktop, choose Desktop Settings from the popup, choose Mouse Actions in the dialog, and click the minus on the far right of the entry for "Vertical-Scroll" to disable the switching function.
User avatar bcooksley
Administrator
Posts
19759
Karma
86
OS
Thanks for updating this. At the time the question was asked the mouse actions functionality did not yet exist I believe, so this configuration option was not available.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
joshaughnessy
Registered Member
Posts
33
Karma
0
OS
thanks rambotribble, you saved my day!
I just found the "mouse actions" options
alfgaarpendragon
Registered Member
Posts
1
Karma
0
rambotribble wrote:Even though this is an old thread, since it is what came up when I searched the topic, it should be answered. The solution is to right-click on the desktop, choose Desktop Settings from the popup, choose Mouse Actions in the dialog, and click the minus on the far right of the entry for "Vertical-Scroll" to disable the switching function.


Well i did this and it did not work, i removed all aditional desktpos remaining only one, it did not work....
it seems KDE does not know what focus is.... i have a window with focus, mouse wheel shoudl scroll it, but instead it switches windows or desktops... that's prettty silly.... even a console knows what focus is and do not event knows what is window... but it does not swap applications without an explicit command...

it seems KDE lacks a better window manager, one that knows how to dispatch events....

This is my first time using KDE and it's really disapointing...
User avatar Hans
Administrator
Posts
3303
Karma
22
OS
alfgaarpendragon wrote:
rambotribble wrote:Even though this is an old thread, since it is what came up when I searched the topic, it should be answered. The solution is to right-click on the desktop, choose Desktop Settings from the popup, choose Mouse Actions in the dialog, and click the minus on the far right of the entry for "Vertical-Scroll" to disable the switching function.


Well i did this and it did not work, i removed all aditional desktpos remaining only one, it did not work....
it seems KDE does not know what focus is.... i have a window with focus, mouse wheel shoudl scroll it, but instead it switches windows or desktops... that's prettty silly.... even a console knows what focus is and do not event knows what is window... but it does not swap applications without an explicit command...

it seems KDE lacks a better window manager, one that knows how to dispatch events....

This is my first time using KDE and it's really disapointing...


Please be mindful of the KDE Code of Conduct, which you agreed to follow when you created your account. Just because something doesn't work the way you expect it to doesn't mean it's bad or needs a replacement. Indicating such is just really disrespectful and non-constructive.

Personally I like that it scrolls whatever is under your cursor, it allows you to scroll another window without losing focus of the current window, e.g. if you're writing something and have a browser open on another screen for researching a topic.


Problem solved? Please click on "Accept this answer" below the post with the best answer to mark your topic as solved.

Image
10 things you might want to do in KDE | Open menu with Super key | Mouse shortcuts
luebking
Karma
0
If you removed all desktops but one, you're certainly not switching to another virtual desktop.
If you do, you did not remove all virtual desktops but one.

Also WMs do not dispatch events at all (that's a technical restriction of X11)
They intercept and conditionally replay them for *inactive* windows, but that's it.

What you encounter may be https://bugs.kde.org/show_bug.cgi?id=320459 which applies to X11 servers with a major capabiliy restriction (and is fixed since two years)

Otherwise I suggest you start over again by describing *precisely* what you do and what happens in return instead of trying to interpret it, for nothing of what you stated makes any sense, sorry.
geevee
Registered Member
Posts
1
Karma
0
ambotribble wrote:
The solution is to right-click on the desktop, choose Desktop Settings from the popup, choose Mouse Actions in the dialog, and click the minus on the far right of the entry for "Vertical-Scroll" to disable the switching function.


Im using KDE4.3.5 and the mouse 'scroll' option does not exist. was it fixed later ? since which version ?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], bartoloni, Bing [Bot], Capitain_Jack, Dave-P, Dibo, Exabot [Bot], gerdeg, gfielding, Google [Bot], Kevaaq, luigitrezzi, lynnux, marthab, raddison, Sogou [Bot], TheraHedwig, Yahoo [Bot]