Reply to topic

Disable desktop switch on mouse wheel / vertical scroll

joshuaa
Registered Member
Posts
1
Karma
0
This bug has re-surfaced on plasma workspace 5.8
right click desktop select desktop settings "mouse actions" there a several options for vertical scroll but none that do nothing.
deleting the action does not stop it from switching desktops.
if you try to use your mouse wheel to adjust volume of kmix tray desktop goes spinning -- super annoying!
if you are trying to zoom in in another application, using scroll wheel, what you're working on goes spinning away!
User avatar Zren
Registered Member
Posts
41
Karma
1
OS
Edit: This is probably not what you're looking for.

Removing the action from the desktop containment works, but the panel is a different containment. Not sure where it's defined, but here's how I fixed it.

Open `~/.config/plasma-org.kde.plasma.desktop-appletsrc` and find `wheel:Vertical;NoModifier=org.kde.switchdesktop` under `[ActionPlugins][...]` and delete the line.

Then restart plasmashell with `killall plasmashell; plasmashell & disown`

Last edited by Zren on Thu Jul 09, 2020 12:36 am, edited 2 times in total.


keitalbame
Registered Member
Posts
2
Karma
0
joshuaa wrote:This bug has re-surfaced on plasma workspace 5.8
right click desktop select desktop settings "mouse actions" there a several options for vertical scroll but none that do nothing.
deleting the action does not stop it from switching desktops.

Which distribution are you using?

Just tested with Arch (plasma-desktop 5.8.4-1 ) and Neon User Edition (20161124-1018). Removing the vertical scroll (with switch desktop option) did stop the desktop switch.
Also tested with switch window and activity and all of them worked when activated and stopped working when vertical scroll was removed.
chaossadept
Registered Member
Posts
2
Karma
0
I've disabled it by Task Manager Settings -> General -> Cycle through tasks with mouse wheel. Hope it will save time for someone)
JDWK
Registered Member
Posts
3
Karma
0
This is the world's most annoying feature. I use a logitech mouse with hyperscroll so if my wheel is still spinning when I move my mouse over the desktop, I am literally playing roulette with which virtual desktop I will land on. Also, this is over VNC and if the network is bogged down, it could be a while before I can get back to work.

I would love to try the suggested methods of turning this feature off, but when I right click on the desktop and choose desktop settings, the "Desktop Settings - Plasma Workspace" window that appears only has one option in the left column. That is "Appearance". There is no "mouse actions" or "task manager settings".

Also, I am not able to follow the manual editing of the config file. There is a file that is very close. ~/.kde/share/config/plasma-desktop-appletsrc
But the "[ActionPlugins]" section does not exist.

It appears my DE has been neutered by my IT department, but I am hoping there is still a way to fix this problem. Here is what I get when I type 'plasma-desktop --version'

Qt: 4.6.2
KDE: 4.3.4 (KDE 4.3.4)
Plasma Workspace: 0.3
Alexandre_Oberlin
Registered Member
Posts
1
Karma
0
chaossadept wrote:I've disabled it by Task Manager Settings -> General -> Cycle through tasks with mouse wheel. Hope it will save time for someone)

Thanks, it works in KDE 5.10x. No upvoting here?
whoopsdecade
Registered Member
Posts
14
Karma
0
rambotribble wrote:Even though this is an old thread, since it is what came up when I searched the topic, it should be answered. The solution is to right-click on the desktop, choose Desktop Settings from the popup, choose Mouse Actions in the dialog, and click the minus on the far right of the entry for "Vertical-Scroll" to disable the switching function.

You only posted once in this forum and it made a difference. Thanks!
ericjs
Registered Member
Posts
12
Karma
0
In Plasma Desktop 5.16.3, I can find no "Task Manager Settings" in the System Settings application. The closest I find is Window Management -> Task Switcher which has some shortcuts, but I don't see any mousewheel mappings there. Personally I want to turn it off because I only care to use the mousewheel for window scrolling, and now and then I'll accidentally have the focus in the wrong place and end up switching tasks.
airdrik
Registered Member
Posts
1854
Karma
5
OS
For the "Task Manager Settings", the task manager is just a widget in the panel, so to access its settings you right-click on the task manager widget (on one of the window buttons or in the space next to it that "belongs" to it) and select Configure Task Manager (could be named a little different depending on the specific task manager widget being used, each of which has slightly different settings available).

You can also switch to a different task manager widget by right-clicking on the task manager space (not on one of the window buttons) and selecting Alternatives... . Additional task manager widgets can be found on the KDE store and may be downloaded by right-clicking on the panel or desktop, selecting Add Widgets, and then hitting the Get New Widgets button on the Add Widgets panel.

(you may find it easier to interact with the settings for these widgets through the panel settings mode when clicking the panel settings button at the far right end of the panel)


airdrik, proud to be a member of KDE forums since 2008-Dec.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], gerdeg, Google [Bot], imperatorstorm, Majestic-12 [Bot], Sogou [Bot], tanmayj316