Reply to topic

Firefox menus and text have disappeared (Arch Linux).

blackplague1347
Registered Member
Posts
1
Karma
0
OS
I was using openbox for a while (couple of days) and then decided to switch to KDE. The switch went well and was pretty effortless. I opened Firefox and it still had that ugly "Raleigh" theme to it. Wanting it to look more like the rest of KDE, I checked out the Arch wiki (I'm using Arch linux, by the way) and found this: https://wiki.archlinux.org/index.php/KD ... plications
Upon following the following instructions to install and change themes to oxygen-gtk, my Firefox has no more text on it, basically (screencap below):

Code: Select all
pacman -S oxygen-gtk
pacman -S gtk-kde4
gtk-kde4 ("System Settings > Lost and Found > GTK style")

Here's what firefox looks like: http://i52.tinypic.com/2r6cxdw.jpg
Interestingly enough, Konquerer wouldn't upload my pic for me (it crashed each time I tried), so I installed Chromium to upload it instead. It won't even start, but maybe the terminal output from running the "chromium" command may have something useful in it? It's missing some gtk-related items, but I don't know what they are nor how to fix the problem.
Here's what the terminal says when I try to run Chromium (similar output results when I run "firefox" from the terminal, minus the segmentation fault):

Code: Select all
/usr/share/themes/qt4/gtk-2.0/gtkrc:335: Unable to locate image file in pixmap_path: "Expander/expander-normal-c.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:337: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:344: Unable to locate image file in pixmap_path: "Expander/expander-prelight-c.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:346: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:353: Unable to locate image file in pixmap_path: "Expander/expander-active-c.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:355: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:362: Unable to locate image file in pixmap_path: "Expander/expander-insens-c.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:364: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:372: Unable to locate image file in pixmap_path: "Expander/expander-normal-sc.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:374: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:381: Unable to locate image file in pixmap_path: "Expander/expander-prelight-sc.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:383: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:390: Unable to locate image file in pixmap_path: "Expander/expander-active-sc.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:392: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:409: Unable to locate image file in pixmap_path: "Expander/expander-normal-se.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:411: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:418: Unable to locate image file in pixmap_path: "Expander/expander-prelight-se.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:420: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:427: Unable to locate image file in pixmap_path: "Expander/expander-active-se.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:429: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:446: Unable to locate image file in pixmap_path: "Expander/expander-normal-e.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:448: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:455: Unable to locate image file in pixmap_path: "Expander/expander-prelight-e.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:457: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:464: Unable to locate image file in pixmap_path: "Expander/expander-active-e.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:466: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:473: Unable to locate image file in pixmap_path: "Expander/expander-insens-e.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:475: Background image options specified without filename
/usr/share/themes/qt4/gtk-2.0/gtkrc:935: Unable to locate image file in pixmap_path: "Shadows/text-entry-focused.png"
/usr/share/themes/qt4/gtk-2.0/gtkrc:938: Background image options specified without filename
[4316:4316:9796277302:ERROR:browser_main.cc(970)] Gtk: Default font does not have a family set
[4316:4316:9796277398:ERROR:browser_main.cc(970)] Gtk: Default font does not have a positive size
[4316:4316:9796284341:ERROR:browser_main.cc(970)] Gtk: Default font does not have a family set
[4316:4316:9796284398:ERROR:browser_main.cc(970)] Gtk: Default font does not have a positive size
[4316:4316:9796284429:ERROR:browser_main.cc(970)] Gtk: Default font does not have a family set
[4316:4316:9796284450:ERROR:browser_main.cc(970)] Gtk: Default font does not have a positive size
[4316:4316:9796287182:ERROR:browser_main.cc(970)] Gtk: Default font does not have a family set
[4316:4316:9796287226:ERROR:browser_main.cc(970)] Gtk: Default font does not have a positive size
[4316:4316:9796287254:ERROR:browser_main.cc(970)] Gtk: Default font does not have a family set
[4316:4316:9796287276:ERROR:browser_main.cc(970)] Gtk: Default font does not have a positive size
Segmentation fault


Judging from that output, I assume there is a problem with GTK that I need to fix? I'm just posting here to make sure it isn't a KDE thing. I haven't been able to find any other forum posts (here, Arch, or elsewhere) that are related to this issue. I also posted this topic on the Arch forums, thus far to no avail.

Thanks.
User avatar bcooksley
Administrator
Posts
19744
Karma
85
OS
You definitely have a problem with your Gtk installation. You may need to adjust your local Gtk configuration file to load Oxygen Gtk so that Gtk doesn't try to use it's default.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
jdwieber
Registered Member
Posts
1
Karma
0
OS
You have probably solved this issue already, but for sake of the next person that comes along; I had a similar problem recently. I have multiple gtk engines installed and they were conflicting. I had to remove the config file ~/.gtkrc-2.0-kde4 because it was overriding the settings I set through the system applet for oxygen-gtk. Once I removed that file everything worked correctly.

 
Reply to topic

Bookmarks



Who is online

Registered users: AHoneybun, allee, automatical, Baidu [Spider], Bing [Bot], boudewijn, davidemme, elav, elvisangelaccio, Exabot [Bot], Google [Bot], leinir, Majestic-12 [Bot], pappad, Psi, sebas, Sudhir Khanger, TheraHedwig, vylaern, Yahoo [Bot]