Reply to topic

Stock Quote updating stopped working

mcarpino
Registered Member
Posts
17
Karma
0
I am unable to update my stock quotes. I'm running Windows 10 Creators Update and KMyMoney 4.8.0. This problem just started and I can't figure out why. Nothing has changed regarding which service I was using. And I did try other services but nothing seems to work.

Here's the error message I keep receiving, Fetching URL http://finance.yahoo.com/d/quotes.csv?s=AMP&f=sl1d1...
Access denied to http://download.finance.yahoo.com/d/quo ... MP&f=sl1d1.
Unable to update price for AMP (empty quote data)

Any advice on how to fix this would be appreciated.
User avatar Steve R.
Registered Member
Posts
13
Karma
0
Same problem. Can't upload stock prices.
wgschaub
Registered Member
Posts
8
Karma
0
OS
If you paste the UR: for Yahoo into a browser's address bar this is what you get:

"It has come to our attention that this service is being used in violation of the Yahoo Terms of Service. As such, the service is being discontinued. For all future markets and equities data research, please refer to finance.yahoo.com."

It may be that a different quotation service needs to be configured.
User avatar ipwizard
KDE Developer
Posts
455
Karma
1
OS
Please see more information on the forum or the bug tracker.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 42.2 64bit, KF5
mcarpino
Registered Member
Posts
17
Karma
0
Someone smarter than me has a solution and this is what I used to start getting stock quotes again. I posted this in case others search here for a solution.

First go to Settings > Configure KMyMoney > Online Quotes > New

Change New Quote Source to Google

In the URL box add https://finance.google.com/finance?q=%1

In the Symbol box add %1

In the Price box add "price"\s+content="((\d+|\d{1,3}(?:[,]\d{3})).\d+)

In the Date box add "quoteTime"\s+content="(\d{4}-\d{2}-\d{2})T

In the Date Format add %y-%m-%d

Check the Skip HTML stripping box

Click Update box

Now go to each stock and change the source to "Google" then you be able to update the stock price.
plucas
Registered Member
Posts
21
Karma
0
mcarpino wrote:Someone smarter than me has a solution and this is what I used to start getting stock quotes again. I posted this in case others search here for a solution.

First go to Settings > Configure KMyMoney > Online Quotes > New

Change New Quote Source to Google

In the URL box add https://finance.google.com/finance?q=%1

In the Symbol box add %1

In the Price box add "price"\s+content="((\d+|\d{1,3}(?:[,]\d{3})).\d+)

In the Date box add "quoteTime"\s+content="(\d{4}-\d{2}-\d{2})T

In the Date Format add %y-%m-%d

Check the Skip HTML stripping box

Click Update box

Now go to each stock and change the source to "Google" then you be able to update the stock price.

I have done all this ancd checked it twice still does not work. No price no date
gcash
Registered Member
Posts
74
Karma
0
OS
plucas wrote:
mcarpino wrote:Someone smarter than me has a solution and this is what I used to start getting stock quotes again. I posted this in case others search here for a solution.

First go to Settings > Configure KMyMoney > Online Quotes > New

Change New Quote Source to Google

In the URL box add https://finance.google.com/finance?q=%1

In the Symbol box add %1

In the Price box add "price"\s+content="((\d+|\d{1,3}(?:[,]\d{3})).\d+)

In the Date box add "quoteTime"\s+content="(\d{4}-\d{2}-\d{2})T

In the Date Format add %y-%m-%d

Check the Skip HTML stripping box

Click Update box

Now go to each stock and change the source to "Google" then you be able to update the stock price.

I have done all this ancd checked it twice still does not work. No price no date


Same here. I also tried keying in the HTML directly into FireFox and it retrieved the correct price.
https://finance.google.com/finance?q=FDRXX.

I want someone to fix Yahoo as it is a royal pain to change it on each security.
User avatar SomeOldFool
Registered Member
Posts
35
Karma
0
OS
mcarpino wrote:Someone smarter than me has a solution and this is what I used to start getting stock quotes again. I posted this in case others search here for a solution.

First go to Settings > Configure KMyMoney > Online Quotes > New

Change New Quote Source to Google

In the URL box add https://finance.google.com/finance?q=%1

In the Symbol box add %1

In the Price box add "price"\s+content="((\d+|\d{1,3}(?:[,]\d{3})).\d+)

In the Date box add "quoteTime"\s+content="(\d{4}-\d{2}-\d{2})T

In the Date Format add %y-%m-%d

Check the Skip HTML stripping box

Click Update box

Now go to each stock and change the source to "Google" then you be able to update the stock price.


Worked for me, thanks! o)
gcash
Registered Member
Posts
74
Karma
0
OS
Changed to google and still a problem.
Get this error, though using the url only in the browser retrieves the correct price and date, as is shown before the error.
================
Fetching URL https://finance.google.com/finance?q=VWINX...
Date found: Thu Nov 23 2017
Unable to update price for VWINX (no price or no date)
Any help ???

thanks

Well, left this post in as it seems that it doesnt like the """""" in the front of:

"price"\s+content="((\d+|\d{1,3}(?:[,]\d{3})).\d+)....should be....
price"\s+content="((\d+|\d{1,3}(?:[,]\d{3})).\d+)

works ok now.

 
Reply to topic

Bookmarks



Who is online

Registered users: 1user2, 1ykos, aureotoshi, Baidu [Spider], bartoloni, Bing [Bot], Exabot [Bot], funkybomber, gfielding, Google [Bot], jacob-em, johssw, jSim, Sogou [Bot], strag, thugo, tosky, Yahoo [Bot]