Reply to topic

Upgrading from Kmymoney 4.6 to 4.8

rpaulton
Registered Member
Posts
1
Karma
0

Upgrading from Kmymoney 4.6 to 4.8

Tue Nov 21, 2017 10:43 am
I have been using this great program for a number of years on Windows and have stuck to the 4.6 release. However, now that the latest release if up to 4.8 I thought I ought to update. However, when I save my existing file (all balanced of course) I get the following errors (I have change the bank name for privacy!)
* Opening date of Account 'Opening Balances' cannot be changed to support transaction 'T000000000000000001' post date.
* Transaction 'T000000000000000001' has a post date '03/04/2012' before one of the referenced account's opening date.
Referenced accounts: Opening Balances
The post date was not updated to '01/01/2013'.
* Transaction 'T000000000000000002' has a post date '26/04/2012' before one of the referenced account's opening date.
Referenced accounts: Opening Balances
The post date was not updated to '01/01/2013'.
* Transaction 'T000000000000002655' has a post date '20/03/2015' before one of the referenced account's opening date.
Referenced accounts: My Bank Direct
The post date was not updated to '08/04/2015'.

Finished: 0 problems corrected. 4 problems still present.



Any ideas how I can resolve this would be much appreciated.
User avatar ipwizard
KDE Developer
Posts
455
Karma
1
OS
The problem is the opening date of the Opening Balances account. Here's how to change that to an appropriate value to solve the issue:
  1. Make a backup of your data and keep it in a safe place. You never know.
  2. Open the KMyMoney settings.
  3. On the General page select the Filter tab.
  4. Make sure, the option Show equity accounts is marked
  5. Close the dialog with OK
  6. Select the Accounts view. It should show Asset, Liability and Equity
  7. Expand Equity which should show you Opening Balances
  8. Press the right mouse button on the Opening Balances and select Edit account... from the context menu
  9. Set the date to 01/01/2012 (or earlier). The exact value does not matter it must only be set to a value prior to the first transaction. According to your message the first usage was on 03/04/2012. You may select 01/01/1900 just to be on the safe side. No negative implications if you do so.
  10. Close the dialog with OK
  11. Unmark the option which you marked in step 4 in case it was not marked using the above steps 2-5 again.
  12. Save the file. The message should not show up again.
Hope that helps.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 42.2 64bit, KF5

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, Exabot [Bot], Google [Bot], jackdinn, La Ninje, rolfreiner, slowersu, Sogou [Bot], vinnywright, Yahoo [Bot], Zeznon