Reply to topic

OFX Import (either method) does not show the desired account

joelmaxuel
Registered Member
Posts
3
Karma
0
Hi, new to the forum.

Using kMyMoney 4.8.0 on Debian Stretch amd64

I use a credit union for my chequing account. It is a bona-fide chequing account for what it's worth. I have brought the issue up on their end already, they have looked into it and it remains a "will-not-fix" since they do not support kMyMoney and the bug is irrelevant in QuickBooks and MS Money (does not encounter the same problem).

When I export the transactions from my chequing account, the resulting QFX/OFX includes a weird entry:
Code: Select all
<ACCTTYPE>SAVINGS


... when I realize the resulting value should be "CHECKING".

Long story short, because of the savings account type, the import process will not match the import file to my chequing account. Only my savings accounts are listed in the drop down. This occours whether I use ofx import or AqBanking importer.

I kludged the first import by editing the file back to CHECKING and all was fine there. Even a subsequent, unaltered import worked fine when there were no imports to other accounts in between (kMyMoney seems to remember the last account used and would display that for the current import) as long as you do not mess with the drop-down selection.

I can see three workarounds:
  1. I continue to modify the import to fix the ACCTTYPE value
  2. I change the account type for that account in kMyMoney to savings
  3. I discover an option for kMyMoney to be agnostic about the account types altogether (like QuickBooks and MS Money)

I would prefer the last option, and I am open to other possibilities as well.

Related topics:
viewtopic.php?f=69&t=143348
viewtopic.php?f=69&t=141660
viewtopic.php?f=69&t=141791
viewtopic.php?f=69&t=127693

The last thread talks about setting the BIC and IBAN to BANKID and ACCTNUM respectively, but that has no effect for me.
gzilla
Registered Member
Posts
1
Karma
0
Same issue here, using KMyMoney 5.0.2 on Fedora 29. When I attempt to import an OFX file that I download from my financial institution for my checking account, instead of displaying my account name & type (checking), the OFX import dialog displays my account as generic "Asset". It used to properly display my account name, and it does show other accounts' names correctly when importing their transactions. I don't know which KMyMoney version used to work properly and whether the regression was due to a KMyMoney code change or my bank's downloaded OFX file content changed. Inspecting the OFX file, I see that it declares the ACCTTYPE to be MONEYMRKT, even though it really is a checking account and not a money market. It could be argued that the flaw lies with the bank for not setting ACCTTYPE to CHECKING, but I claim that the software should not depend on that field value to identify the account. The bank account number and routing number should be sufficient to accurately identify the account.

Even though the KMyMoney OFX importer wizard doesn't identify the target account by name, it does show the correct account number, and if I proceed, it does properly import the transactions to correct account anyway. Still, this is behavior is confusing and undesirable. Like the OP, if I manually edit the OFX file, replacing MONEYMRKT with CHECKING for ACCTTYPE, the import wizard dialog then properly identifies my account by name.
User avatar ipwizard
KDE Developer
Posts
673
Karma
3
OS
A workaround has been added with this change to the source code.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5

 
Reply to topic

Bookmarks



Who is online

Registered users: Arkengheist, askinner, Baidu [Spider], Bing [Bot], evisse, Exabot [Bot], gfielding, Google [Bot], kjeram, MDAD, pasis, segri, Sogou [Bot], Yahoo [Bot]