Reply to topic

Exchange Rate/Price editor broken?

pasis
Registered Member
Posts
25
Karma
0

Exchange Rate/Price editor broken?

Thu May 02, 2019 2:26 pm
Hi,

I updated to 5.0.4 (win) and noticed that Exchange Rate/Price editor does not work anymore.

I tried to add dividends as usually but was not able to do so since the "to amount" box does not accept decimal indicator at all and exchange rate/price has conversion 1$ = ? €/1€=? $.

I tried 5.0-247-windows-msvc2017_64-cl and -371... with a same symptoms.
Update stock and currency prices seems to work though, still the exchange price is as above mentioned
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
Can you explain the steps you take in detail (which view you start with, which actions you do, what you enter and click, etc.) so that we can try to duplicate the problem and find a solution? Thanks in advance.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
pasis
Registered Member
Posts
25
Karma
0
I get same problem at least two ways.

First, I open price editor.

tools -> price editor.

I select any commodity and Select modify.
The Exchange Rate/price editor pops up. I can enter only integers to the "to amount" field

Same problem occurs when I enter the any non-euro dividends in ledger for investment type account. Account has currency in Euros, and i enter dividend in USDs. When i have set the prices and the same "exchange rate/price editor" pops up, exactly same symptoms happens, "to amount" accepts only integers and Exchange rate/price does not have any meaningful values.

These were working before 5.0.4
pasis
Registered Member
Posts
25
Karma
0
It seems that problem is really in exchange rate/price editor part. I tried to enter the bought shares to investment account and I tried to record CAD interest income to cad account. Exactly same symptoms with exchange rate/price editor. So basically I cannot record any non-euro events at the moment.
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
Thanks for the ongoing support to analyze the problem. I will take a look at it.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
pasis
Registered Member
Posts
25
Karma
0
I am not sure, but could this change be reason for the problems?

https://cgit.kde.org/kmymoney.git/commi ... 2fe21cf187
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
Yes, it's exactly the change I wanted to look at. I remember it from a while ago. Thanks for extracting it and providing the details.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
Next question: can you enter fractions if you use a comma as decimal symbol instead of a dot?


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
pasis
Registered Member
Posts
25
Karma
0
No, i can't. Only integer is accepted in the field, so nothing but numbers cannot be entered. not any other symbol does not appear. I cannot use dot or comma as a decimal symbol.
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
Hmm, the precision is controlled by the price precision of the security. What is your setting there?


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
pasis
Registered Member
Posts
25
Karma
0
Precision is 4 for currencies and 5 for other securities. Tools ->update stock and currency prices... works perfectly and I have up to date values on database. I just cannot enter any non-euro events to ledger because exchange Rate/price editor does not accept decimals anymore.
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
Can you try to check if the problem is reproducible using an anonymized version of your data? Please see the manual how to create this file.


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
pasis
Registered Member
Posts
25
Karma
0
Yes. Exactly the same symptoms when trying to enter any non euro values with anonymized data.
Image
This is the popup window what I was talking about. I really think it is problem with the entryfields. Both of those fields doesn't accept anything but integers. This screenshot is from real data
User avatar ipwizard
KDE Developer
Posts
718
Karma
3
OS
One more try: can you execute the following command and post the result here?
zgrep CURRENCY xxx.kmy

or since you have the problem with USD but not EUR the output of the following command would also be ok
zgrep CURRENCY xxx.kmy | grep USD
zgrep CURRENCY xxx.kmy | grep EUR


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.0 64bit, KF5
pasis
Registered Member
Posts
25
Karma
0
Hi. Greping (with windows tools) with USD gave me a following results.

<SECURITY trading-market="NASDAQ" symbol="KO" pp="5" id="E000005" name="Coca-Cola " type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NASDAQ" symbol="GLAD" pp="5" id="E000006" name="Gladstone capital corp" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="LTC" pp="5" id="E000007" name="LTC Properties" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="SO" pp="4" id="E000011" name="Southern Co" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="WSR" pp="4" id="E000012" name="Whitestone REIT" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NASDAQ" symbol="T" pp="4" id="E000013" name="At&amp;T" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NASDAQ" symbol="FTR" pp="4" id="E000014" name="Frontier Communications Corp" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="MAIN" pp="4" id="E000018" name="Main Street Capital" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="OHI" pp="4" id="E000020" name="Omega Healthcare Investors Inc" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="O" pp="2" id="E000022" name="Realty Income Corp" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NYSE" symbol="SNH" pp="4" id="E000023" name="Senior Housing Properties Trust" type="0" trading-currency="USD" rounding-method="7" saf="1">
<SECURITY trading-market="NASDAQ" symbol="VZ" pp="4" id="E000025" name="Verizon Communications Inc" type="0" trading-currency="USD" rounding-method="7" saf="1">

But i do not see any reason how would this help since the data itself seems to be identical with the EUR data. (sample below)

<SECURITY trading-market="NASDAQ" symbol="NDA FI" pp="4" id="E000008" name="Nordea Bank Abp" type="0" trading-currency="EUR" rounding-method="7" saf="1">
<SECURITY trading-market="NASDAQ" symbol="SAMPO" pp="4" id="E000010" name="Sampo Oyj" type="0" trading-currency="EUR" rounding-method="7" saf="1">

The problem is not in the data itself Since i can replicate the error with every other currency (NOK, SEK, CAD and USD). I am pretty sure that something wrong with how to enter the values with the "exchange rate/price editor",since it doesn't accept anything else but integers, and every other function seems to work perfectly. So basically i cannot complete entering the data unless i use integers. (for example i can set something to be exactly 2

I have exactly the same problem with CAD account when recording CAD dividends and income category is in EUR.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], davide445, everwaerde, Google [Bot], hiteshshah, Mamarok, millaan, philippea, raphaelra, Sanette, Vangelis62, Yahoo [Bot]