Reply to topic

Quicken for Mac 2007 Import using QIF

User avatar quotron
Registered Member
Posts
3
Karma
0

Quicken for Mac 2007 Import using QIF

Mon Apr 27, 2020 11:35 pm
I am struggling to import my meager portfolio that I've been tracking in Quicken for Mac 2007 (qfm2007). I'd like some pointers on what to do to fix my portfolio's *.qdfm file formatting so that it will work (timescale of that qdfm file spans 1998 - today).

My 2003 Mac (iOS 10.3) hard drive is getting increasingly louder and I'd like to make the jump before it fails. I have decided to use KMyMoney on an used Windows 7 machine I purchased after an exhaustive evaluation of every portfolio tracker out there including Investment Account Manager (IAM). I think KMyMoney is the best tool around given the portfolio analysis and reporting options it has.

I am having issues getting my qfm2007 QIF file to import using any of the date formats or other import settings using KMyMoney 5.0.6 on my Win7Pro SP1. Only the first listed account (a single stock IBM and it's set of purchased shares that I use to confirm Quicken's calculations) will import. The only item that imports successfully in that file is the liabilities section for my mortgage's outstanding balance. The QIF file of only those IBM share transactions is shown further below.

I did however create a new file with only the new IBM share purchase transactions in QFM2007 shown below into a qfm2007 file format (*.qdfm) then exported it to a QIF file. It imported fine into KMyM and that *.kmy file is found in this Google Drive link:

https://drive.google.com/open?id=1FmYbC ... hjsthKvPHF

That QIF first listed account uses theoretical purchases and reinvested dividends of IBM stock shown below - used only to check Quicken's calculations and to compare Quicken to other new potential portfolio trackers.
Date Security Trans Shares Out Shares In CumlShares Share Price Fees
1/3/2017 IBM Buy 100 100 167.19
4/3/2017 IBM Buy 100 200 174.5
7/3/2017 IBM Buy 100 300 155.58
8/1/2017 IBM RD 100 400 152.94 5
9/19/2017 IBM 400 144.82

Thank you in advance.

- Quotron
User avatar quotron
Registered Member
Posts
3
Karma
0
If I clear out a bunch of the first part of the QIF file, some data will import but constantly asks this for each transaction:

The date entry "1/29/10" read from the file cannot be interpreted through the current date profile setting of "". Pressing "Continue" will assign todays date to the transaction. Pressing "Cancel" will abort the import operation. You can then restart the import and select a different QIF profile or create a new one.

I have the import setting as %m %d %y on the plugin (corrected)

- Q

Last edited by quotron on Tue Apr 28, 2020 9:13 pm, edited 1 time in total.
User avatar ostroffjh
Registered Member
Posts
89
Karma
0
OS
1/29/10 sounds like month/day/year, but you say %d %m %y. Try changing it to %m %d $y.
User avatar quotron
Registered Member
Posts
3
Karma
0
I meant to post month / day / year. (I've tried all sorts of input settings - to no avail). I've heard QFM2007 format (Quicken 2007 for Lion) was a standard format but hard to import into Quicken for Windows.
User avatar ipwizard
KDE Developer
Posts
928
Karma
4
OS
quotron wrote:The date entry "1/29/10" read from the file cannot be interpreted through the current date profile setting of ""

That empty string puzzles me. It should contain the QIF-profile name. Maybe, you don't have one.

The importer should present a combo box in the first dialog with a set of (at least one) QIF profiles. It is a known issue, that this list is empty and no default is provided if you just installed KMyMoney. That could be causing your problems. Here's the workaround for the missing profile issue:

Goto Settings/Configure KMyMoney... and select the Plugins view at the bottom of the list. Search for the QIF importer or QIF exporter. Any of them will do. Press the configure button on the right of the entry. A dialog box is opened showing the Default profile (which was just created when you opened that dialog). Exit these setting dialogs with OK. Now try to import your file again. The Combobox should now show Default as the only profile.

Regarding the date format: KMyMoney tries to figure out the date format by analyzing the contained data. If that is ambiguous it will ask the user as in your case. You can create a QIF profile that suits your settings and KMyMoney should not ask you again.

Hope that helps you to get a bit further. QIF is certainly not the best format for what we are doing here :)

Hint: you should check the opening dates of your accounts and setup some feasible values (prior to the first transaction contained). The QIF importer might use today's date if it does not have other information (e.g. opening balance transaction).


ipwizard, proud to be a member of the KMyMoney forum since its beginning. :-D
openSuSE Leap 15.1 64bit, KF5

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Garthhh, Google [Bot], Sogou [Bot]