Reply to topic

KMyMoney 3.97 for KDE4 and 1.0.4 for KDE3 now available

User avatar Hei Ku
Registered Member
Posts
784
Karma
3
OS
The KMyMoney Team is proud to announce the immediate availability of version 3.97 of KMyMoney. This is the third beta release for the KDE4 platform, and probably our last beta before the first release candidate. As with previous releases, this version is still considered beta and not recommended for general use. We continue to get feedback from the community and find those issues that are not immediately apparent during development.

This release has seen a lot of work in two different areas. The first, and probably most important to users, is fixing bugs. The second is to continue porting pieces of the code away from Qt3Support to a full KDE4 native mode.

Over 30 bugs have been fixed, new and old, during this release, from trivial one-liner quirks to more complicated ones, like porting whole widgets due to small incompatibilities with KDE SC 4.4. As for the previous release, only 8 bugs remain open at this point. We do have a lot more wishlist items, which we hope to attend to in due course.

The account and category selectors, among others, have been ported to a KDE4-native mode. From a user's perspective, there will be no apparent change other than some style improvements, and that's how it should be. From a development point of view, however, it is important, because eventually all similar widgets will follow the same path.
Several other minor lists and widgets have been ported. So far, it has been a learning experience, which the team is leveraging to plan future steps of the port. An outstanding aspect of the port is that we usually end up with fewer lines of code than we previously had, and with more readable and maintainable code, which is a good trend and it shows the advantages of using the new frameworks offered by the KDE4 platform.

There continues to be constant feedback and joint work with the packagers in different distributions, which shows in better and more stable packages in the main distributions. Also, we are improving our communication with them to help in bug fixing and triaging, which eases their work and helps us get more feedback, and in turn results in more bugs fixed and a better packaging and easier installation methods for users.

For those still using the KDE3 platform version, the team has also released version 1.0.4. This maintenance release contains some fixes and improvements we made during the development of the KDE4 version and backported to it, and an overhauled Finnish translation of the user interface.

Continuing our quick release cycles, you can expect the first release candidate version to be available in 6 weeks from now, on May 15th.

[0] Download location: http://sourceforge.net/projects/kmymoney2/files/
[1] Original announcement: http://soliverez.com.ar/drupal/node/169


Hei Ku, proud to be a member of the KMyMoney Development Team since January-2008
Oripi
Registered Member
Posts
17
Karma
0
OS
I would like to test this beta (3.97) of KMyMoney on my Mac. Currently I use the 1.0.3 of KMyMoney that is available through Macports? Do you know who is responsible for the MacPort version ? Is there any chance to see this new version (3.97) on MacPorts soon ?

If no, how can I build KMyMoney on my Mac without using MacPorts ?

PS : Currently 1.0.3 need X11 on Mac, does Qt4 need X11 too ? Is there a way to have a native KMyMoney on Mac ?

Thanks


Oripi, proud to be a member of KDE forums since 2008-Nov.
john_hudson
Registered Member
Posts
549
Karma
2
OS
I tried to download 3.97 from Packman but what I got is labelled 3.96. Not sure whether the problem is with Packman or the labelling.


John Hudson, proud to be a member of KDE forums since 2008-Oct.
User avatar Hei Ku
Registered Member
Posts
784
Karma
3
OS
It's the labeling. The splash screen is ok, but the About box is not.
Sorry about that.


Hei Ku, proud to be a member of the KMyMoney Development Team since January-2008
User avatar NickElliott
Registered Member
Posts
258
Karma
3
OS
I'm running version 1 on KDE4 but can't upgrade from 1.03 to 1.04, I get the following:

kmymoney2:
Depends: libfontconfig1 (>=2.8.0) but 2.6.0-1ubuntu12 is to be installed
Depends: libsqlite3-0 (>=3.6.22) but 3.6.16-1ubuntu1 is to be installed

Not really a problem as 1.03 works fine for me but I thought I'd mention it - usually these upgrades work seamlessly using Synaptic.


NickElliott, proud to be a member of KDE forums since 2008-Oct.
User avatar Hei Ku
Registered Member
Posts
784
Karma
3
OS
Where are you installing it from? So that we can report that to the responsible packager.


Hei Ku, proud to be a member of the KMyMoney Development Team since January-2008
User avatar NickElliott
Registered Member
Posts
258
Karma
3
OS
I'm using Clay's ppa:

http://ppa.launchpad.net/claydoh/ppa/ubuntu karmic main


NickElliott, proud to be a member of KDE forums since 2008-Oct.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], boudewijn, bovender, claydoh, Google [Bot], grinder, Mace68, Majestic-12 [Bot], mcoudert, quisimodo, sandro4912, Sogou [Bot], TheraHedwig, Voronwe13