Reply to topic

disable touchpad while typing???

dutchkind
Registered Member
Posts
16
Karma
0
OS

disable touchpad while typing???

Wed Oct 03, 2012 6:22 pm
Some kde4 releases ago "disable touchpad while typing" was available and very useful. Then it disappeared and I am left with a touchpad that with the lightest touch is activated placing my cursor in a different part of my text, very annoying. Question is: Is this useful feature ever going to return? I saw only an old thread of more than 3 years ago about the topic.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
This was never an official KDE feature, which explains it's disappearance. Your distribution likely shipped a touchpad configuration module from kde-apps.org as part of their default KDE installation.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
dutchkind
Registered Member
Posts
16
Karma
0
OS
Ok, understandable. But when googling for this I see a lot of hits so obviously I am not the only one. So would there be any plans to add this officially to KDE?
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
The developer(s) of the software in question would need to ask about moving it into KDE proper. This would be done by them on the [email protected] and [email protected] mailing lists.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
DeMus
Registered Member
Posts
134
Karma
0
Not usable for everyone but I simply disabled the touchpad completely in BIOS. Connect a mouse and it's all you need.
dutchkind
Registered Member
Posts
16
Karma
0
OS
I just discovered that starting synaptiks opens a window similar to the touchpad config of KDE, but with the option to disable the touchpad while typing!
zhoumin
Registered Member
Posts
1
Karma
0
There is an easy way of accessing in CMOS setting and disable touchpad
User avatar Mamarok
Manager
Posts
3848
Karma
11
OS
Still, there is a regression since KDE 4.10.90 where it is no longer possible to disable the touchpad, not even with the relevant keys on a Lenovo Thinkpad. So either the distribution modified something in the X server, or it is KDE related. I suspect the latter as there were no updates for the X Server when I upgraded to that KDE version.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu 19.10, Plasma 5.17.0, Frameworks 5.62.0, Qt 5.12.4, kernel 5.3.0-18
jonsson
Registered Member
Posts
1
Karma
0
I had the same problem (and syndaemon won't work after upgrading to 13.10). But I found an already installed program called synaptiks that works flawlessly! Do you have it to? Look for it in the start menu or just run the command and it will show up in the system tray. The thing is that it does not show up in the System settings > Input devices. Stange!
coreylal
Registered Member
Posts
1
Karma
0

Re: disable touchpad while typing???

Tue Dec 10, 2013 11:20 am
boy I didn't even notice or know there was such a feature... sad that it's gone before I even tried

online casino gratis

Last edited by coreylal on Thu Dec 12, 2013 4:34 am, edited 2 times in total.
User avatar bcooksley
Administrator
Posts
19763
Karma
87
OS
KDE has for a release or two now shipped native software to disable the touchpad in certain circumstances. I can't recall if this was just when the enable/disable touchpad button was pressed, or if it extended to disabling while typing as well.

In any instance, Synaptiks (not part of KDE releases) does provide the desired functionality and is still being shipped by distributions as far as I know.


KDE Sysadmin
[img]http://forum.kde.org/content/bcooksley_sig.png[/img]
User avatar Mamarok
Manager
Posts
3848
Karma
11
OS

Re: disable touchpad while typing???

Wed Dec 11, 2013 11:52 am
Unfortunately it seems synaptiks is not shipped anymore by some of them, at least I can't find it in the regular Ubuntu and Kubuntu repositories. This is probably due to the package not having a maintainer anymore.


Mamarok, hanging out in the Amarok forum since August, 2007
Currently running Kubuntu 19.10, Plasma 5.17.0, Frameworks 5.62.0, Qt 5.12.4, kernel 5.3.0-18

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], claydoh, cmb, cylverbak, Google [Bot], JesusM, smankowski, YaCy [Bot]