Reply to topic

Mauvais affichage du PHP dans Firefox/KDE

dismark
Registered Member
Posts
6
Karma
0
Bonjour,

J'utilise KDE (Kubuntu) depuis plus de 4 ans et un problème est apparu dans l'affichage de mes applications PHP sous Firefox.

Avec KDE 15.10 et la version 45 de Firefox, tout fonctionnait correctement.

Depuis la version KDE 16.04 et les versions ultérieures de Firefox (une dizaine puisqu'on en est à Firefox 55), l'affichage de mes applications PHP est incorrect : les zones affichées n'ont plus la même taille, ainsi que les boutons de mes applications.

J'ai soumis le problème à Mozilla, et jusqu'à ce jour, je n'ai pas d'explication réelle, ni de solution, si ce n'est d'utiliser la version 45 de Firefox.

D'ailleurs ces mêmes applications sous Windows avec les dernières versions de Firefox/Windows n'ont pas le problème. De même en utilisant Chromium, sous KDE, tout est OK.

J'ai testé ces mêmes applications dans des environnements différents : Kubuntu et Debian avec KDE, et les résultats sont identiques.

De plus le soucis apparaît quelque soit l'ordinateur : j'ai deux PC : un AMD et un Intel avec des chipsets graphiques différents qui présentent les mêmes symptômes.

A ce stade, on pourrait supposer que KDE n'est pas en cause, sauf que la gestion de l'affichage est peut-être en conflit avec l'affichage de Firefox.

Je souhaiterai joindre deux images : la première est réalisée sous Firefox 45 et la seconde sous Firefox 55, mais je ne vois pas comment sur le forum

Si quelqu'un a une idée de la provenance de ce bug, j'apprécierai fortement son aide.
bbo
Registered Member
Posts
60
Karma
0
OS
Bonjour,

Désolé de répondre ce sujet avec retard.

Si je comprends bien ce que tu expliques, ce n'est pas un problème de Plasma, ni un problème de PHP. C'est plutôt un problème de rendu de tes pages dans le navigateur. Regarde donc plutôt du côté de tes feuilles de styles.

Les différences de rendu entre Chrome/Chromium et Firefox peuvent arriver car les 2 navigateurs n'utilisent pas le même moteur de rendu.

[...]je n'ai pas d'explication réelle, ni de solution, si ce n'est d'utiliser la version 45 de Firefox.

Je déconseille. C'est une version qui n'est plus supportée par Mozilla.

dismark wrote:Je souhaiterai joindre deux images : la première est réalisée sous Firefox 45 et la seconde sous Firefox 55, mais je ne vois pas comment sur le forum

Les administrateurs du forum ont désactivé la possibilité de télécharger des images sur le forum. Tu dois donc les héberger ailleurs : soit sur ton serveur perso, soit sur un service tiers comme imgur. Puis tu postes le lien de l'image sur le forum.
dismark
Registered Member
Posts
6
Karma
0
Depuis j'ai résolu mon problème : celui-ci provenait de l'utilisation de bordures dans les feuilles de style. En supprimant les bordures pour les boutons créés en PHP, tout fonctionne correctement.
Je peux maintenant utiliser les dernières versions de Firefox sous KDE
Donc, problème résolu !
Merci pour le suivi.

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], Bing [Bot], Google [Bot], Majestic-12 [Bot], uyenb, Yahoo [Bot]