Reply to topic

[SOLVED] plasma-widget-menubar only displays "..." & "File"

tpd
Registered Member
Posts
1
Karma
0
OS
Hi there,

I emerged plasma-widget-menubar just fine (with ~amd64 keyword) and I was able to add it to a panel on my desktop, but currently the widget is only displaying "File" and it's not hiding the actual menubar from windows on my desktop. On my laptop running Ubuntu 12.04, apt-getting plasma-widget-menubar works as expected.

I'm using KDE 4.8.3 with kde-misc/plasma-widget-menubar-0.1.17

Thanks for any help!

Here is the solution that worked for me:
https://github.com/Etrnls/Etrnlay

1. Create "/usr/local/portage" directory if it doesn't already exist.
2. Download the x11-misc/appmenu-qt/appmenu-qt-0.2.6.ebuild file and place it in /usr/local/portage/appmenu/x11-misc/appmenu-qt directory
3. Download the x11-misc/appmenu-qt/Manifest file and place it in the /usr/local/portage/appmenu/x11-misc/appmenu-qt directory.
4. Make sure that PORTDIR_OVERLAY="/usr/local/portage" exists in your /etc/make.conf file.
5. Finally, run emerge appmenu-qt

After restarting kdm, all of my native KDE applications respond to the plasma-widget-menubar now. You might also want to repeat the same steps for "appmenu-gtk" if you use a lot of GTK applications as well.

Reply to topic

Bookmarks



Who is online

Registered users: andreasdimo, Baidu [Spider], Bing [Bot], gogor, Google [Bot], ipwizard, jesusgautamah, Lachu, oki, Sogou [Bot], wolfn