Reply to topic

gtk-key-theme-name="Emacs" -- not working well with Tbird

pablo
Registered Member
Posts
5
Karma
0
OS
I'm having trouble finding the right forum for this problem so if there's a better forum, please let me know and I'll re-post there. Thx!


Hi,

I'm currently on openSUSE 13.2, KDE 4.14.2.

To my ~/gtkrc-2.0-kde4, I've added the directive gtk-key-theme-name="Emacs" There appears to be an issue with this setting and Thunderbird.

When I'm in Thunderbird's composer, composing an HTML message, if I type CTRL-B to toggle the Bold switch, a Backspace is generated. If I comment out the directive, emboldening toggles correctly.

Any advice on which component I should file a bug against? Or is there something I've missed? This used to work ... a while ago on (openSUSE 12.1 but not with the latest version of KDE available on it ... I was hoping it'd be fixed in openSUSE 13.1 ... :)

Thanks a lot!
-pablo
airdrik
Registered Member
Posts
1854
Karma
5
OS
Just reading your description of the problem, I'm inclined to believe that this doesn't to have anything to do with KDE. Does it still occur if you log into another desktop (e.g. Gnome, XFCE, Unity, or other GTK-based environments; you may need to install one if you haven't already - for the sake of the experiment I'd suggest the fairly lightweight XFCE) and select the Emacs theme using that desktop's theme switcher?
If so then the bug is somewhere between the Emacs GTK theme and Thunderbird and you should try asking for advice over in their forums.


airdrik, proud to be a member of KDE forums since 2008-Dec.
pablo
Registered Member
Posts
5
Karma
0
OS
Hi,

Thank you for your ideas. You're right, it has nothing to do with KDE. I'll have to check with the Thunderbird team to see what their thoughts are on the issue.

Today I set up a VM using openSUSE 13.2 and using XFCE, I replicated the problem.

Cheers,
-pablo
pablo
Registered Member
Posts
5
Karma
0
OS
Hi,

A bit of research and I believe I've found the issue. I believe the problem was a bug in the Emacs definition that I was taking advantage of. The bug got fixed and now it's working as it should: CTRL-B should go back a character. To revert to the old way ...

The Emacs theme's definition can be found in /usr/share/themes/Emacs/gtk-2.0-key/gtkrc

Using the link [1], I made the following changes to ~/.gtkrc-2.0:

Code: Select all
gtk-key-theme-name="Emacs"
#
# Override/tweak the Emacs theme with my settings below.
#
binding "gtk-emacs-override"
{
   unbind "<ctrl>b"
   unbind "<ctrl>i"
   unbind "<ctrl>u"
}

class "*" binding "gtk-emacs-override"


[1] - https://bbs.archlinux.org/viewtopic.php?pid=1017546#p1017546

 
Reply to topic

Bookmarks



Who is online

Registered users: Bing [Bot], Google [Bot], joebuckley, mmizak, orontin, Yahoo [Bot]