Reply to topic

Improve Locale Configuration in Plasma 5

21

Votes
21
0
damir
Registered Member
Posts
1
Karma
0
I live in the US, but I like to use a 24-hour clock. That means that I don't fit neatly into any of the locales offered by Plasma 5. I'm sure I'm not the only one in this situation. Here's what it's like for a user who has an odd preference like me (tl;dr: it took me half an hour to find out that what I want is not possible):

After I installed Plasma 5, I noticed the clock was a 12-hour clock and wanted to change it. In its right-click menu, there's a helpful option: "Set Time Format". Unfortunately, the dialog that opened up was very different from what I was used to from KDE SC 4. Instead of being able to fine-tune my locale settings, I had to select a country/language combination from a drop down list having maybe 200 options? No worries, I'm pretty sure the UK's time locale should default to a 24-hour clock... Yes, the example shows a 24-hour clock! Time to log out and log back in... But wait, now the week starts on Monday! Silly me, I knew the UK started their week on Monday. All I have to do is try another country. Maybe Australia? Wait, the example doesn't show the first day of the week, so I have to log out and back in again... Nope, they use Monday as well. Hmm. After trying several countries, it looks there is no country with a locale that both starts the week on Sunday and uses a 24-hour clock (not to mention still using the odd US short date format of MM/DD/YY; did I mention the examples also don't show what the short date looks like?)


Sorry about the rant, but it's a bit hard to explain just how frustrating the current system is. I understand that Plasma 5 dramatically changed the way locale configuration and handling is done compared to KDE SC 4. However, it would be nice if there was some way to go beyond a prescribed set of formats for each country. At the very least, the configuration dialog should show more information in the examples, so that I wouldn't have to log out and back in to find out what day the week starts on, or what a short date looks like in a given locale.
User avatar Soukyuu
Registered Member
Posts
71
Karma
0
OS
I think the time format option should be split up into time format, date format and date language options.

As another example, I'm in Germany, but preferer using English locale on my computer. So in current situation, I am either forced to live with the 12h format, or with a mix of German and English in the UI.
Notsonoble
Registered Member
Posts
5
Karma
0
I also would like to run a 24 hour clock with US locale settings.
aexoxea
Registered Member
Posts
4
Karma
0
OS
Very similar experience here; I wanted to override the default date and time format from that in my (correct) locale, and initially thought I must have been overlooking something when I couldn't see how to do so. My searches on forums here and elsewhere yielded the same results as others: that the system for locale handling was overhauled for Frameworks/Plasma 5, and that the new system doesn't currently have the capability to override locale defaults.

The workarounds listed here have been promulgated -- try different combinations of locales, or create a 'custom' locale file with the desired parameters -- but I agree with the original poster that a longer-term solution is needed, one which permits locale defaults to be overridden through System Settings.
User avatar phonglam
Registered Member
Posts
2
Karma
0
OS
I am stucked in the same problem. I love my English-Style Desktop with KDE, but now, with KDE Plasma 5, the time format is in Vietnamese and 24h-format. Is there any way to change this?

Thanks alot.
choward
Registered Member
Posts
1
Karma
0
+1 Not being able to fine tune these settings is a big regression from KDE4
User avatar jaimesilva
Registered Member
Posts
3
Karma
0
Big, Huge regression.

I'm also missing calendar options on clock. Been able to see my country holidays and days off just clicking on the clock was a great KDE feature. Those are the little great features that I like to brag about KDE, losing them makes KDE loss value :'(
markj
Registered Member
Posts
1
Karma
0
Hi all, new to KDE here - I've never liked KDE, but 5 really looks good so I'm giving it a spin -- loving everything about it so far. Is there a bug tracker where we can report this? Is this even a bug, or is it rather a missing feature?

Just to add to what's been mentioned already, all I want to do is set my time in the Digital Clock widget in the panel to show 24h format 15:54, instead of 3:54 PM, it seems impossible to do without changing the locale of my whole system.
kduprey
Registered Member
Posts
1
Karma
0
I have always had a 24Hr clock set, it bugs me having a 12Hr clock.
liujed
Registered Member
Posts
1
Karma
0
Looks like this issue is a result of a back-end change (from KLocale to QLocale): https://bugs.kde.org/show_bug.cgi?id=345378#c8

According to an earlier comment in that same bug, the plasmashell developers are aware of this issue, and are figuring out how to fix it.
User avatar undoIT
Registered Member
Posts
75
Karma
1
OS
liujed wrote:Looks like this issue is a result of a back-end change (from KLocale to QLocale): https://bugs.kde.org/show_bug.cgi?id=345378#c8

According to an earlier comment in that same bug, the plasmashell developers are aware of this issue, and are figuring out how to fix it.


Glad they are working on fixing this. I too always use 24 hour clock and I like to specify a custom date format for the system tray and also for the Date column as listed in Dolphin. Also, I want to have my region set to US but I prefer to use metric for units.


Image GNU/Linux user since 2007 | Keyboard Shortcuts | Coupon Code Swap
emrecio
Registered Member
Posts
13
Karma
0
OS
Yeah, the issue here in addition is the first day of the week being off.
shmerl
Registered Member
Posts
250
Karma
1
OS
Is there any way to specify to use first day of the week as Sunday in the calendar widget (in plasmashell clock), or it's also tied to locale and can't be set explicitly?
emrecio
Registered Member
Posts
13
Karma
0
OS
*sigh* this is still an issue. See the following bug, it seems like we're not the only ones... https://bugs.kde.org/show_bug.cgi?id=340982
tharrrk
Registered Member
Posts
2
Karma
0
Hi. For Kubuntu I made a quick&dirty fix. Read more below.

https://bugs.kde.org/show_bug.cgi?id=345378#c37

Cheers

 
Reply to topic

Bookmarks



Who is online

Registered users: Alexa [Bot], andreaaxx, Baidu [Spider], Bing [Bot], claydoh, Drizzt321, Google [Bot], Mamarok, Sam Illingworth, Yahoo [Bot]