Reply to topic

Screen Tearing On Laptop Screen But Not External Monitor

User avatar Lord_LolzWorth
Registered Member
Posts
1
Karma
0
Hello All,

I have a HP OMEN laptop with Intel i7 CPU and Nvidia GTX 1050 GPU.

Running KDE Neon 5.12 with Plasma 5.12.4, x64 bit.

I have successfully installed the latest Nvidia Driver from the repository (driver version 384.111) and it seems to be performing well in games. The issue is Vsync specific to my laptops monitor. When I hook up an external monitor via HDMI, there is no tearing problems. However, on the laptop monitor it is very noticeable.

Things I have tried:

Set Display Compositor to the following:
- Scale Method = Accurate
- Rendering = OpenGL 3.1
- Tearing Prevention = Full Screen Repaints

Add KWIN_TRIPLE_BUFFER=1 to /etc/profile.d/kwin.sh

An additional thing I have noted that any changes made to xorg.conf are overridden at boot, replaced with the original values of the below:
Code: Select all
Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:[email protected]:2:0"
    Option "AccelMethod" "None"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:[email protected]:0:0"
    Option "ConstrainCursor" "off"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option "AllowEmptyInitialConfiguration" "on"
    Option "IgnoreDisplayDevices" "CRT"
EndSection



Any assistance to resolving this would be greatly appreciated.

Thanks,


EDIT 1: If I export xorg.conf via the Nvidia x server tool, xorg.conf looks like this before reboot:
Code: Select all
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 384.111  ([email protected])  Wed Dec 20 00:05:28 PST 2017

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "None"
    BusID          "PCI:[email protected]:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    BusID          "PCI:[email protected]:0:0"
EndSection

Section "Screen"
    Identifier     "intel"
    Device         "intel"
    Monitor        "Monitor0"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "on"
    Option         "IgnoreDisplayDevices" "CRT"
    Option         "ConstrainCursor" "off"
    SubSection     "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection



After the reboot it returns to the value in my original post.

Edit 2: It appears that the xorg.conf file has stuck with the Nvidia settings, has not resolved issue however.
User avatar Neros
Registered Member
Posts
1
Karma
0
I have exactly the same issue! I feel less alone...

Have you found a solution?

 
Reply to topic

Bookmarks



Who is online

Registered users: Baidu [Spider], BigaAl, Bing [Bot], dcihon, Google [Bot], luther, Sogou [Bot], sorcerer, stnowell, suongmai, Yahoo [Bot]